Contact Support

Flix for Story

This page covers the workflows artists use to create and edit their artwork using Flix and Photoshop. Discover how to import and edit panels, add dialogue and annotations, and record your pitch. Find out how to use the Photoshop actions to work with layer comps, the frame timeline, and layers and groups.

Importing Panels into Flix

You can import panels and other file formats using the file browser or by dragging directly into Flix.

1.   In the main toolbar, click the Import to Flix button.

This opens a file browser.

2.   Select one or multiple files.

Note:  You can import the following files: .png, .psd, .jpeg, .jpg, .mov, .mp3, and .wav.

3.   Click Open.

OR

From your file browser, drag one or more files directly into Flix's Panel Browser.

Tip:  You can also drag folders into the Panel Browser for Flix to import their contents.

Your files are imported in the sequence. When audio, such as .mp3 or .wav files are imported, Flix displays an audio icon in the Status bar.

Note:  The audio contained in imported .mov files is not retained.

Sending Artwork from Photoshop to Flix

See Flix and Photoshop section.

Making Changes to the Edit (Sequence Revision) in Flix

In Flix, you can make changes to your edit in several ways:

Moving panels around by selecting one or more, and dragging them where you want to place them.

Removing panels from your current edit by clicking the Trashcan icon in the Edit toolbar.

Re-using panels by using the Copy and Paste buttons in the Edit toolbar, which creates new panels re-using the same panel, timing, and dialogue.

Editing Panels Already in Flix

To make changes to panels in your edit (sequence revision), you can open and edit them in third-party applications. See Flix and Photoshop section.

Adding or Editing Dialogue

You can easily add dialogue to your panels in both the Story and Dialogue workspaces. Dialogue is displayed as subtitles in the Player, which you can turn on and off.

Method 1

Flix's Story workspace (default) contains the Dialogue controls in the Panel Properties pane in the Dialogue tab.

To add and edit dialogue:

1.   Select the required panel and enter text in the Dialogue box. Press Enter to add new lines.

This adds dialogue to the selected panel, which is displayed as subtitles in the Player.

Note:  If you select multiple panels, the same dialogue is added to all selected panels.

2.   Use the Dialogue tools to modify the formatting of your text.
3.   Click the Toggle Subtitles button to turn the subtitles on and off.

Tip:  Use the Undo and Redo buttons, located under the breadcrumb, to undo or redo your recent actions.

4.   Click Save to save all new dialogue.
5.   Keep track of the dialogue history by clicking on the Dialogue History dropdown menu.

Method 2

In the Story workspace at the top-right corner, click the Switch Workspace button and select Dialogue workspace. The Dialogue workspace contains a Panel Browser and a Dialogue pane.

To add and edit dialogue:

1.   Select the required panel and enter text in the Dialogue box. Press Enter to add new lines.

This adds dialogue to the selected panel.

Note:  If you select multiple panels, the same dialogue is added to all selected panels.

2.   Use the Dialogue tools (Bold, Italics, Underline, and Strikethrough) to modify the formatting of your text.

Tip:  Use the Undo and Redo buttons, located under the breadcrumb, to undo or redo your recent actions.

3.   Save your sequence revision to save all new dialogue.

Note:  Keep track of the dialogue history by clicking on the Dialogue History dropdown menu.

Annotating Panels

You can annotate your panels directly in the Player, which is located at the top-right corner of the application in the Story workspace.

1.   In the Panel Properties pane, toggle the annotations on by clicking the Pencil button at the bottom of the Player.

2.   Click the Color Palette button then click again to select a color.
3.   Click and hold the Pencil button then drag the slider to adjust the thickness of the pencil.
4.   Make annotations on your panel.

Annotated panels are tagged with the pencil icon to indicate they contain annotations.

5.   Use the Eraser tool to partially erase your annotations or use the Trash tool to completely remove the annotations.
6.   On the main toolbar, click the cogwheel button and enable the Annotations filter to only display panels containing annotations.

Recording a Pitch

Periodically, you may want to pitch sequences to others involved in the project to present your work. Pitching allows you to do a rough timing for your sequence, for example depending on the action you may want to stay longer on one panel.

You can access the Pitch workspace through the Player in the Panel Properties pane.

1.   If you want to record audio while pitching, navigate to File > Preferences > Audio and select an Input Device. If you already have audio in your sequence and don't want to override it, in the Player click the Microphone button to disable it.

Note:  When pitching with audio, use the Volume button to make sure the volume is set properly.

Tip:  You can switch to Full Screen mode by clicking the Full Screen button. Press Esc to exit the Full Screen mode.

2.   Click the Record button to start pitching.

In the red bar at the top of the Player, the Time and the Duration timers are running.

3.   As soon as you reach the required duration, press the right arrow key to move to the next panel.

By switching to the next panel, you stop the recording of the duration for the current panel and start the recording for the next one.

4.   Keep recording the duration for each panel until the end of the sequence or click the Record button again to stop recording.

In the Panel Properties pane, select the Properties tab to check the updated duration for your panels. You can also change the duration in the Properties tab directly by entering a new duration or using the arrows.

Tip:  When playing the sequence, press A to add an audience at the bottom of your panels.

Flix and Photoshop

To make your artwork, you can use Photoshop, whether you are using Layer Comps, Timeline Frames, or Layer stack. Flix takes care of naming, organizing, and managing your files so that you don’t have to. You can easily make revisions to existing panels in Flix with a double-click and save, and there’s no need to waste time figuring out naming conventions, server structures, and versioning systems.

Setting Up Flix to Work with Photoshop

To use Photoshop, you first need to select Photoshop as your sketching tool then set up the required version and install the plug-ins.

1.   Ensure Photoshop is closed while setting preferences in Flix.
2.   Navigate to File > Preferences > Third Party Apps.
3.   In the Sketching tab, select Photoshop.
4.   In the Photoshop tab:

set the Executable preference by browsing to the version of Photoshop you want to use with Flix.

set the Panel Open Behavior:

Open as Separate PSD - Opens the selected panels in Photoshop as separate .psd files.

Open in Layer Comps - Opens the selected panels in Photoshop as layer comps.

Open in Timeline - Opens the selected panels in Photoshop in the Timeline.

enable or disable Always Open Master Image - This opens the .psd file in Flix as a master image, which means that all information is saved, such as hidden layers and empty groups.

click Install Plugins. This installs the Photoshop scripts to run the Photoshop actions.

Note:  Installing Photohsop plug-ins may require admin privileges. Ask your system administrator for assistance.

5.   To open the Photoshop actions, in Photoshop, navigate to Window > Extensions > Flix.

The Photoshop Actions open in a new tab called Flix.

Creating a New Panel and Sending it to Flix

1.   In Photoshop, in the Flix tab, select the aspect ratio at the top of the list to match the one of your show.

Note:  Select whether you want to Always Send Original as Master. This sends the original file, unedited, as a Master file to Flix. This does not insert anything in the edit (sequence revision).

2.   Select New Template.
3.   Draw on the panel.
4.   Select Current Image.

Flix sends the panel to the edit (sequence revision). The panel is inserted after the currently selected panel

Creating Thumbnails and Sending them to Flix

1.   In Photoshop, open the Flix tab and select the aspect ratio at the top of the list to match the one of your show.

OPTIONAL: Select whether you want to Always Send Original as Master. This sends the original file, unedited, as a Master file to Flix. This does not insert anything in the edit (sequence revision).

2.   Click New Thumbnails.
3.   Draw on the thumbnails.
4.   Click Send Thumbnails.

Flix sends the thumbnails to the edit (sequence revision). The thumbnails are inserted as nine new individual panels after the currently selected panel, if any.

Note:  Make sure the File > Preferences > Always Open Master Image preference is disabled, otherwise when you open one of the nine thumbnails from Flix to Photoshop it will open the original panel containing the nine thumbnails.

Working with Flix and Photoshop's Layer Comps

OPTIONAL: Select whether you want to Always Send Original as Master. This sends the original file, unedited, as a Master file to Flix. This does not insert anything in the edit (sequence revision).

In Photoshop, with your .psd file open, open the Flix tab and click Each Layer Comp or Selected Layer Comp.

Photoshop sends to Flix each (selected) layer comp as a single panel.

Making Revisions to Layer Comps

If a master image is available for your layer comps:

1.   Ensure the File > Preferences > Third Party Apps > Photoshop > Always Open Master Image is enabled.
2.   Select the panel you want to work on.
3.   In the main toolbar, click the Open in Sketching app button.

In Photoshop, this opens the master image with all information including hidden layers and empty groups.

In Flix, this opens the Master file that the panel is linked to in Photoshop.

4.   After you are done working on your master image, save the .psd file and select Replace Each Layer Comp from the Photoshop actions.

In Flix, this updates panels from the first selected to the last, going from the first layer comp to the last.

OR

If you haven't started your work with layer comps or don't have a master image:

1.   Navigate to File > Preferences > Third Party Apps > Photoshop > Panel Open Behavior and select Open in Layer Comps.
2.   In your edit (sequence revision), select the required panels you want to open as layer comps.
3.   In the main toolbar, click the Open in Sketching app button to send your panels to Photoshop.

This opens one .psd file containing a layer comp for each selected panel, each layer comp containing the layers associated to the selected panels.

4.   After you are done working on your layer comps, save the .psd file

This automatically replaces the opened panels with the updated layer comps.

Working with Flix and Photoshop's Frame Timeline

Note:  Select whether you want to Always Send Original as Master. This sends the original file, unedited, as a Master file to Flix. This does not insert anything in the edit (sequence revision).

In Photoshop, with your .psd file open, open the Flix tab and click Each Frame.

Photoshop sends each frame in the Frame Timeline to Flix as a single panel.

Making Revisions to Frames

If a master image is available for your frames:

1.   Ensure the File > Preferences > Third Party Apps > Photoshop > Always Open Master Image is enabled.
2.   Select the panel you want to work on.
3.   In the main toolbar, click the Open in Sketching app button.

In Photoshop, this opens the master image with all information including hidden layers and empty groups.

In Flix, this opens the Master file the panel is linked to in Photoshop.

4.   After you are done working on your master image, save the .psd file and select Replace Each Frame from the Photoshop actions.

In Flix, this updates panels from the first selected to the last, going from the first frame to the last.

OR

If you haven't started your work with frames or don't have a master image:

Note:  When you are working in a Frame Timeline without any original master image, in the Frame Timeline, click the Hamburger button and disable New Layers Visible in All Frames. This will display all the frames in the Frame Timeline otherwise all the panels will be the same.

1.   Navigate to File > Preferences > Third Party Apps > Photoshop > Panel Open Behavior and select Open in Timeline.
2.   In your edit (sequence revision), select the required panels you want to open in a timeline.
3.   In the main toolbar, click the Open in Sketching app button to send your panels to Photoshop.

This opens one .psd file containing one frame for each selected panel, each frame containing the layers associated to the selected panels.

4.   After you are done working on your frames, save the .psd file

This automatically replaces the opened panels with the updated frames.

Working with Flix and Photoshop's Layers/Groups

OPTIONAL: Select whether you want to Always Send Original as Master. This sends the original file, unedited, as a Master file to Flix. This does not insert anything in the edit (sequence revision).

In Photoshop, with you .psd file open, open the Flix tab and click any of the following:

Note:  Make sure the layers or groups you want to send are visible otherwise they will be ignored.

Each Layer - Sends to Flix each visible layer in an image as a separate panel.

Each Layer + BG - Sends to Flix each visible layer in an image as a separate panel but keeps the background the same for each one.

Each Layer + FG/BG - Sends to Flix each visible layer in an image as a separate panel but keeps the background and foreground the same for each one.

Selected Layer(s) - Sends to Flix only the selected layers of the image as a new panel.

Making Revisions to Layers and Groups

If a master image is available for your layers:

1.   Ensure the File > Preferences > Third Party Apps > Photoshop >Always Open Master Image is enabled.
2.   Select the panel you want to work on.
3.   In the main toolbar, click the Open in Sketching app button.

In Photoshop, this opens the master image with all information including hidden layers and empty groups.

In Flix, this opens the Master file the panel is linked to in Photoshop.

4.   After you are done working on your master image, save the .psd file and select any layer actions (see above) from the Photoshop actions.

In Flix, this updates panels from the first selected to the last, going from the first layer or group to the last.

OR

If you haven't started your work with layers or groups or don't have a master image:

1.   Navigate to File > Preferences > Third Party Apps > Photoshop > Panel Open Behavior and select Open as separate PSD.
2.   In your edit (sequence revision), select the required panels you want to open as layers or groups.
3.   In the main toolbar, click the Open in Sketching app button to send your panels to Photoshop.

This opens one .psd file containing a layer or group for each selected panel, each layer or group containing the layers associated to the selected panels.

4.   After you are done working on your layer comps, save the .psd file

This automatically replaces the opened panels with the updated layers or groups.