13. Introduction to GafferThree nodes

This video introduces lighting for our scene using a GafferThree node.


Contents:

In the video:

To create a GafferThree node and light:

1.   In the Node Graph tab, create a GafferThree node by pressing Tab, typing G and T, and choosing the GafferThree entry from the node creation menu.
2.   With the cursor over the GafferThree node, press the E key to set the node's edit flag and bring up the node's parameters in the Parameters tab.
3.   In the table of objects of the GafferThree node in the Parameters tab, right-click and choose Add 3Delight > Area Light from the context menu.

To transform the light’s position:

1.   Select the light's location in the Scene Graph tab, or select the light's geometric representation (also sometimes called the light icon) in the Viewer (Hydra) tab.
2.   In the Viewer (Hydra) tab, click on one of the transform manipulator tool buttons, for example Translate, Rotate, or Scale, or press on one of their associated keyboard shortcuts: W, E, or R.
3.   Drag one of the selected manipulator's handles in order to translate, rotate, or scale the light.

To constrain a light to a specific object:

1.   In the GafferThree node's Object tab in the Parameters tab, turn on enable aim constraint.
2.   Middle-mouse drag the intended target object's scene graph location from the Scene Graph tab onto the targetPath parameter in the aim constraint options section in the Parameters tab.