17. Mesh Lights & Using a Prune node

This video shows how to create a mesh light within a GafferThree node and remove the original geometry using a Prune node.


Contents:

In the video:

To create a Mesh Light:

1.   Right-click in the GafferThree node's table of objects in the Parameters tab and choose Add 3Delight > Mesh Light from the context menu.
2.   Middle-Mouse drag the geometry from the scene graph to the Source Mesh field in the Object tab of your meshLight parameters.
3.   Click on the Material tab and adjust the material parameters of your mesh light to achieve the desired look.

Using a Prune node:

1.   In the Node Graph tab, create a Prune node by pressing Tab, typing P and R and choosing the Prune entry from the node creation menu.
2.   Place the node somewhere downstream of the GafferThree node.
3.   With the cursor over the Prune node, press the E key to set the node's edit flag and bring up the node's parameters in the Parameters tab.
4.   Middle-mouse drag a geometry location from the Scene Graph tab onto the Add Statements button of the Prune node's CEL parameter in the Parameters tab. For example /root/world/geo/primitive.

The object this scene graph location path refers to is now removed from the scene. To learn more, see Prune nodes.