Keyboard Shortcuts

Keyboard shortcuts provide quick access to the features of Katana. The following tables show these shortcuts.

Warning:  Currently, widget focus is not correctly restored when a dialog is opened and closed, causing certain keyboard shortcuts to stop working.

Conventions

The following conventions apply to instructions for mouse-clicks and key presses.

LMB means click or press the left-mouse button.

MMB means click or press the middle-mouse button

RMB means click or press the right-mouse button.

When you see the word “drag” after a mouse button, this tells you to press and hold the mouse button while dragging the mouse pointer.

Keyboard shortcut combinations with the Ctrl, Alt, and Shift keys tell you to press and hold the key and then type the specified letter.

For example, “Press Ctrl+S” means hold down the Ctrl key, press S, and then release both keys.

Note:  Keyboard shortcuts in the tables appear in upper case, but you do not type them as upper case. If the Shift+modifier does not appear before the letter, press the letter key alone.

Note:  In many Linux windows managers, the Alt key is used by default as a mouse modifier key. This can cause problems in 3D applications where Alt is used for camera navigation in 3D environments.

You can use key mapping to assign the mouse modifier to another key, such as the (Super or Meta) key, but the method changes depending on which flavor of Linux you're using. Please refer to the documentation on key mapping for your particular Linux distribution for more information.

General Shortcuts

Keyboard Shortcut(s)

Action

Ctrl+\

Repeat the previous render.

Alt+middle-click and drag

Pans any scrollable area. (When used in the Node Graph it zooms in and out.)

Ctrl+,

Opens the Preferences dialog.

Ctrl+E

Exports the currently selected portion of the script as highlighted in the Node Graph. This saves the selected nodes as a script.

Ctrl+F

Within the Node Graph, Parameters, Scene Graph, Attributes, and Project Settings tabs, opens a Search dialog.

Ctrl+I

Imports a script into the current script.

Ctrl+MMB Drag

Allows dragging and dropping of attribute information.

Ctrl+Shift+MMB Drag

Allows dragging and dropping of attribute information.

Ctrl+N

Creates a new script. (Doesn’t work inside the Node Graph.)

Ctrl+O

Opens a previously created script.

Ctrl+Q

Quit the application.

Ctrl+R

Redo the last undone action.

Ctrl+S

Save the current script.

Ctrl+Shift+S

Save the current script to a new file (Save As).

Ctrl+Z

Undo the last action.

Esc

Cancel the current render.

F4 Show shelf items.
F5 Flush caches.
F6

Toggle implicit resolvers in the Scene Graph tab.

F7

Toggle the Render Only Selected Objects option in the Scene Graph tab.

F8

Toggle the Auto-Key All option.

P

Start an interactive render from the current view node.

Spacebar

Maximizes the pane currently below the mouse pointer. If the pane is already maximized, Spacebar restores it to its previous size.

Backdrop Node Shortcuts

Keyboard Shortcut(s)

Action

[

Moves the Backdrop node the mouse is over to the back.

]

Moves the Backdrop node the mouse is over to the front.

Alt+L

Toggles the locked state of a Backdrop node.

Ctrl+LMB

Selects everything within the border of a Backdrop node.
Double LMB Opens the Backdrop node editor.

Curve Editor Shortcuts

Keyboard Shortcut(s)

Action

A Frames all selected.
D Shows domain slider.
Delete Deletes keyframe.
Esc Exits insert mode.
F Frames selected.
H Shows heads up labels.
Insert Enters insert mode.
S Cycle snapping mode.

Dope Sheet Shortcuts

Keyboard Shortcut(s)

Action

A Frame all.

Ctrl+A

Select all.
H

Toggles tooltips.

Home Frame global in/out.
W Frame working in/out.

Messages Shortcuts

Keyboard Shortcut(s)

Action

Ctrl+A

Select all.

Crtl+C

Copy message.
Delete Delete message.

Monitor Shortcuts

Keyboard Shortcut(s)

Action

Period (.) Toggles the pixel probe display.
Grave Accent (`) Globally toggles the visibility of the monitor manipulators.
+/- Zooms into and out of the image.

1-8

Switches to catalog bookmark.

1-8 (Long Press)

Sets a catalog bookmark.

Alt+K

If mask display is enabled, steps to next mask.

Alt+RMB Drag

Zooms into and out of the image.

Alt+Up Arrow/Down Arrow

Adjusts the gamma of the image.
C Shows RGB channels as a color image.

Ctrl+Home

Resets display exposure (fstop) offset to 0.

Ctrl+LMB drag

Pixel probe.

Ctrl+Up Arrow/Down Arrow

Increment/decrement display exposure (fstop) offset by 1/4 stop.
Double LMB Sets the center of 2D render spiral.
F

Fits images to Monitor tab.

Home Reset to 1:1 zoom level, with origin in lower-left corner.
K Toggles the mask display.
MMB drag Pans image.
Mouse wheel Zooms into and out of the image.
O Toggles the overlay image on/off.
O (press and hold) Sets and uses the current render as the overlay image.

R/G/B/A/L

Shows red, green, blue, alpha, luminance channels as grayscale.

Shift+RMB

Toggle Region of interest (ROI) enabled state.

Shift+RMB Drag

Draws and enables Region of interest (ROI).
S Swaps front/back catalog display items.
Tab Switches between monitor and catalog views.
U Toggles the underlay image on/off.

U (press and hold)

Sets and uses the current render as the underlay image.

Up Arrow/Page Up/Down Arrow/Page Down

Views next catalog item/Views previous catalog item.

Ctrl+Page Down

Selects the next available AOV, stopping at the last available AOV.

Ctrl+Page Up

Selects the previous available AOV, stopping at the first available AOV.

Node Graph Shortcuts

Keyboard Shortcut(s)

Action

Period (.)

Adds a Dot node to the Node Graph. A Dot is only created if the mouse is over a connection, you are connecting two nodes with one end connected, or a node is selected.

Backtick ()

Creates a connection between nodes. Press it first with the mouse over the starting node, and a second time over the node to connect to.

/

Pans the view to the node at the other end of the connection. (Only works when the mouse is hovering over one side of a connection.)

1-9

Begin or end connection with numbered output port.

A

Frames the complete node tree within the Node Graph.

Alt+Any Arrow

Nudges the selected node or nodes a small distance in the direction of the arrow.

Alt+. (period)

Dims the nodes that are unconnected to the viewed node.

Alt+D

Toggles disabled state of selected nodes.

Alt+E

Opens the currently selected node’s parameters settings within the Parameters tab.

Ctrl+F

Opens a Search dialog for the tab.

Alt+M

Toggles the thumbnail state of selected nodes.

Alt+G

Creates a GroupStack node with the currently selected node moved inside.

Alt+S

Toggles snapping nodes to grid while dragging within the Node Graph. When selected, moving nodes happens in steps that correspond to a grid.

Alt+T

Toggles teleport link visibility.

Ctrl+C

Copies the currently selected node or nodes to the buffer.

Ctrl+Backspace

Goes up a level from level under mouse pointer.

Ctrl+Down Arrow

Selects all nodes downstream of the currently selected node(s).

Ctrl+MMB

Ctrl+Return

Enter group under mouse pointer.

Ctrl+Shift+Backspace

Goes up to /root level from level under mouse pointer.

Ctrl+Up Arrow

Selects all nodes upstream of the currently selected node(s).

Ctrl+V

Pastes the buffer to the Node Graph.

Ctrl+X

Deletes the currently selected node or nodes from the Node Graph and copies them to the buffer.

D

Toggles the disable state of the node currently under the mouse pointer.

Delete

Deletes the selected node from the Node Graph.

E

Opens the Parameter tab of the node currently under the mouse pointer in the Parameters tab.

Esc

Cancels whatever operation you are in the middle of, such as connecting nodes.

F

Frames the currently selected node(s) within the Node Graph.

F2

When a single node is selected, opens a pop-up to edit the name of that node.

G

Creates a Group node with the currently selected nodes moved inside.

J

Displays the Jump-to menu, which comprises all Backdrop Nodes that have the bookmark flag set. Selecting one of the menu options frames its corresponding Backdrop Node within the Node Graph.

L

Rearranges selected nodes, in the Node Graph, for clarity.

M

Merges the selected nodes by connecting their outputs to a Merge node. This functionality is the same as selecting Edit > Merge Selected Nodes from the Node Graph tab menu.

N

Displays the right-click node creation menu at the current mouse location.

P

Creates PrimitiveCreate nodes in the Node Graph, with their name and nodeType parameters set to match a specific type of primitive.

Q

Toggles showing expression links within the Node Graph. When selected, nodes that derive their parameters via an expression that references another node have this relationship shown via a black dashed line.

R

Replaces the currently selected node with a node selected from the node creation menu without disconnecting it, which is displayed when the key is pressed. Typing additional characters filters the displayed list.

Return or Enter

When the pointer is over a node, opens a pop-up to edit the name of that node.

Shift+~

Swaps inputs one and two on the node below the mouse pointer on a 2-input node.

T

Displays the node type of the node below the mouse pointer.

Tab

Displays the node creation menu. Typing additional characters filters the displayed list.

U

Ungroups all nodes from within the currently selected Group node and brings them into the current view, deleting the Group node.

V

Makes the currently selected node the view node for the scene graph. After pressing this key, the Scene Graph tab displays a snapshot of the scene at that point within the script.

X

Removes all connections to or from the selected node, extracting it from the node tree. Expression references to or from the node remain unchanged.

Y

Aligns selected nodes.

Parameters Shortcuts

Keyboard Shortcut(s)

Action

D

Toggles the disabled state of node.

Ctrl+F

Opens a Search dialog for the tab.

LMB Drag

Adjusts parameter value in Parameters tab.

Ctrl+LMB Drag

Adjusts parameter value (finer grain).

Shift+LMB Drag

Adjusts parameter value (coarser grain).

Python Console Shortcuts

Keyboard Shortcut(s)

Action

Alt+Up Arrow

Previous history.

Alt+Down Arrow

Next history.

Ctrl+X

Cut.

Ctrl+C

Copy.

Ctrl+V

Paste.

Ctrl+Return

Execute entered script.

Scene Graph Shortcuts

Keyboard Shortcut(s)

Action

Ctrl + +

Expands All/Expands branch.

Ctrl + -

Collapses All/Collapses branch.

+

Expands location(s).

-

Collapses location(s).

Left Arrow

Selects parent location of focused location/Collapses location.

Right Arrow

Selects first child location of focused location/Expands location.

Ctrl+Left Arrow

Selects parent locations of selected child locations.

Ctrl+Right Arrow

Selects all child locations of selected parent locations.

Ctrl+Up Arrow

Moves selection up.

Ctrl+Down Arrow

Moves selection down.

Click

Working Sets: Sets states of selected locations to be Included.

Shift+Click

Working Sets: Sets states of selected locations to be Included with Children.

Ctrl+Click

Working Sets: Sets states of selected locations to be Excluded.

Ctrl+Shift+Click

Working Sets: Sets states of selected locations to be Excluded with Children.

Alt+Click

Working Sets: Resets states of selected locations to their minimum allowed states.

Timebar Shortcuts

Keyboard Shortcut(s)

Action

[

Sets global in from current frame.

]

Sets global out from current frame.

+/-

Zooms in and out of timeline.

Alt+LMB Drag

Zooms in and out of timeline.

Ctrl+Left Arrow

Move the current frame to the previous keyframe.

Ctrl+LMB Drag

Selects a new active range.

Ctrl+Right Arrow

Move the current frame to the next keyframe.

Home

Sets active range from global in/out.

Left Arrow/Right Arrow

Decrement the current frame by Inc. (Inc can be found on the Timeline.)/Increment the current frame by Inc. (Inc can be found on the Timeline.)

Mouse wheel

Zooms into and out of the active range.

Viewer Shortcuts

Keyboard Shortcut(s)

Action

Grave Accent (`)

Displays the manipulators.

+/-

Adjusts the size of the manipulators.
0 Selection > Subd level 0 (base).
1 Selection > Subd level 1.
2 Selection > Subd level 2.
3 Selection > Subd level 3.
4 Displays wireframe.
5 Displays shaded (filmlook).
6 Displays shaded (simple).
7 Displays all lights.
8 Displays selected lights.
A Toggle quick editor.

Alt+L/R/M

Mono mode, left/right/main view.

Alt+S

Stereo mode.
Backspace Selection history backward.

Shift+Backspace

Selection history forward.

Ctrl+B

Displays proxies bounding box.

Ctrl+G

Displays proxies geometry.

Ctrl+Shift+G

Displays both proxies bounding box and geometry.

Ctrl+LMB

Removes object from selection.

Ctrl+LMB drag

Removes objects from selection.

Ctrl+Shift+LMB

Adds object to selection.

Ctrl+Shift+LMB drag

Adds objects to selection.

C

Toggles between the perspective and orthographic views for the default persp camera.

D

Makes rotate (world) manipulators appear.

Pressing D a second time makes the rotate (world) manipulators appear around the COI.

E Makes rotate manipulators appear.
Esc Removes all manipulators from view.
G Displays grid.
H Hides selection.
LMB Selects object.

LMB Drag

Selects objects.

N Displays normals.
P Pins manipulator.
Q Removes all transform manipulators from view.
R Makes scale manipulators appear.
S Makes translate (world) manipulators appear. Pressing it repeatedly toggles between the Translate (world) and Translate Around COI manipulators.

Shift+~

Displays annotations.
T Changes background color to black.

Alt+T

Changes background color to gray.

Shift+T

Changes background color to white.
Tab Displays the manipulator measurement tool.
U Unhides selection.

V

Look through the selected object.

W Makes transform manipulators appear.

X, Y, or Z

Switches the camera to look along the positive axis, aligned with the Center of Interest. The COI position and distance are maintained and the camera can be panned and tumbled as a perspective camera.

Shift+X, Y, or Z

Switches the camera to look along that negative axis, aligned with the Center of Interest. The COI position and distance are maintained and the camera can be panned and tumbled as a perspective camera.