Mari Preferences Dialog

The Mari Preferences dialog is described below with functions for how to access it. A list of the controls on the dialog can be found in the table below.

What It Does

Lets you set preferences for how Mari works.

How to Access It

Menubar | Edit > Preferences

Color Tab

Setting

Type

What it does

Notes

Color

Color Management Defaults | Color Picker Maximum

entry box, slider

The maximum color intensity that can be chosen in the color picker.

From 1 to 65,365; defaults to 4,096.

Color Management Defaults | Color Profile

dropdown

Sets the default color profile for
displaying colors on your monitor.

 

Display | Center
F-Stop

entry box, slider

Sets the center F-Stop value for when the Gain reset button is clicked.

 

General | Color Swatches and Pickers (advanced and intermediate color management modes only)

dropdown

Specify whether the color swatches and color pickers within Mari are based on the OCIO colorspace for the project (found within the File > Settings), the colorspace listed within the Color Manager (View Transform) palette, or the Raw data, which has no colorspace transformation.

 

General | Image Transform Clamping (advanced and intermediate color management modes only)

dropdown

Specify whether the colorspace transforms that are applied to images are clamped between the values of 0 and 1, with:

Off - not clamping the values applied to any image at all. Clamping can still occur in places like the Paint through tool when either the paint buffer or target image set is 8-bit.

Byte - clamping only when the colorspace transform is applied to images that are 8-bit.

All - clamping all images regardless of bit depth.

 

General | Detect Path Colorspace

checkbox

When reading image files from disk, enable this option to detect the colorspace of the image from the colorspace names found in the image's file name and path.

 

General | 3D LUT Size

dropdown

Sets the size of the display LUT loaded by the View Transform toolbar.

You may sometimes notice artifacts on the canvas when your LUT size is too small. Increase the size of the LUT here.

General | Transform Cache Size

entry box, incrementers

Sets the maximum memory size Mari uses to cache data that has undergone a colorspace transformation.

You can assign a shortcut for the Transform Cache Size option in the Manage Keyboard Shortcuts Dialog.

Data Tab

Setting

Type

What it does

Notes

Data

Autosave |
Frequency (Mins)

entry box, incrementers

Sets how frequently (in minutes) Mari automatically saves your work.

 

Channel Cache | Resolution Mode

dropdown

Determines if Mari caches at the given channel’s resolution or a lower proxy level. Setting this to Fixed uses the Default resolution and Type
listed below.

This can speed up the caching process if you don’t require the full
resolution of the
channel to be cached.

Channel Cache | Default
Resolution

dropdown

If the Resolution Mode is set to Fixed, Mari caches at the selected
resolution.

This can save time when caching large patches if you don’t require the full resolution while working.

Channel Cache | Default Type

dropdown

If the Resolution Mode is set to Fixed, Mari caches at the selected bit depth.

This can save time when caching large patches if you don’t require the full resolution while working.

Channels | Export Transform

dropdown

Specifies which colorspace transform method to use when performing flattening and baking on export:

Accurate - performs all colorspace transforms on the CPU. This gives the most mathematically correct results but incurs a cost of decreasing the speed of export.

Fast - performs all colorspace transforms on the GPU. This maximizes the speed of export, but may introduce errors due to the math in some cases, being an approximation to the true methods.

Automatic - uses the CPU or GPU, on case-by-case basis, based on the accuracy of colorspace transform itself.

 

Channels | Importer

dropdown

Sets the mode for the import
function. One of:

Fast Importer - takes over your Mari session while it imports the textures, but works quicker.

Background Importer - works in the background, letting you paint and work on your project, but takes longer.

 

Channels | Exporter

dropdown

Sets the mode for the export
function. One of:

Fast Exporter - takes over your Mari session while it exports the
textures, but works quicker.

Background Exporter - works in the background, letting you paint and work on your project, but takes longer.

 

Channels | Export Mask Stacks

dropdown

Determines how mask stacks are
exported. Either:

Export Baked Mask Stack and an Invisible Group - exports a group along with the mask stack in order to group the exported masks.

Export Baked Mask Stack Only - exports on the mask stack with nothing else as part of the export.

 

Channels | Autosnapshot

dropdown

Sets whether automatic snapshots are enabled or disabled. The options available are:

Disabled - Disables the
Autosnapshot feature.

Enabled with Limit - Enables the
Autosnapshot feature but limits the number of autosnapshots that can be stored in the Snapshots palette.

Enabled - Unlimited - Enables the
Autosnapshot
feature without a limit on the number of
autosnapshots that can be stored in the
Snapshots palette.

 

Channels | Autosnapshot Limit

entry box, slider

When Enabled with Limit is
selected, Mari limits the number of
automatic snapshots that are stored in the Snapshots palette to the
number specified by the
Autosnapshot Limit. The
maximum value is 20.

 

General | Fix Edge UVs

dropdown

Sets whether Mari should “fix” any UVs that sit on the edge of the patch. With this on, you can paint models that have UVs at the edge of the patch.

 

General | Channel Input

dropdown

When creating a new project, sets whether the New Channel dialog box adds either:

Single Channel - a single channel.

Channel Presets - a set of
channels that you select from a list of presets.

 

Project | Thread Count

entry box, slider

Sets the number of free threads that are available for background tasks.

These are in
addition to the
dedicated data
management threads (of which there are three per project directory).

Project | Max Memory

entry box, incrementers

Sets the maximum amount of memory Mari uses for the DDI cache blocks. You can't set this to a value higher than 80% of the memory you have available (rounded to the nearest half-GB). For example, if you have 6GB of memory available, you can't set Max Memory to a value higher than 4.5GB. This is to avoid using all the physical memory available.

DDI is the data caching system used in Mari.

The Reset (R) icon resets the maximum memory value to 2 GB.

Project | Cache Space Update Interval

entry box, slider

Sets the interval, in seconds, that the cache drives are checked for sufficient disk space.

 

Project | Project Location entry box, button

Specifies the location where Mari stores the project data.

This can only be modified if the MARI_CACHE environment variable has not been set, and no project is loaded.

Do not delete this directory! If you do, you will lose all your project data and existing work.

GPU Tab

Setting

Type

What it does

Notes

GPU

Baking and Projection |Mip-Map Generation

dropdown

Sets the method used when generating mip-maps for images.

Accurate - Image data is linearized before down-sampling and then converted back into the native colorspace. This gives the most mathematically correct results but incurs a cost of decreasing the speed of processes such as baking.

Fast - No linearization is performed and the down-sampling is done in the native colorspace of the image data. This maximizes the speed of processes such as baking, but can introduce errors due to the math being non-linear.

 

Baking and Projection | Render Bucket Size

dropdown

Sets the maximum tile size for tiled render operations (for example, unprojections). Setting this to a lower value improves accuracy but may result in slower render operations.

 

Baking and Projection | Bake Bucket Size

dropdown

If baking calculation has to be divided into sections in order to continue efficiently, this specifies the
maximum square size of these
sections.

Increasing the number of squares per section can increase baking time, but may impact stability.

Canvas | Deferred Shading

checkbox

Specifies whether to use deferred shading. This is on by default and should increase painting and
navigation speed.

 

Canvas | Deferred Texture Array

checkbox

Turns Deferred Texture Array on/off. When this is active, Mari makes more efficient use of OpenGL.

 

General | Max Image Memory

entry box, incrementers

Sets the maximum amount of
additional GPU memory Mari uses for tasks other than painting, for example, filter operations.

 

General | Deferred Quad Split Count

entry box, slider

Sets the quad split count. Increasing this value splits the canvas into
smaller parts.

Used in conjunction with Draw Batch Size, adjusting this value can improve stability and prevent Windows driver resets.

General |Threaded Operations Allowed

checkbox

If this is enabled then operations requiring threaded OpenGL can be executed.

 

General |Cubemap Arrays Allowed

checkbox Enabling cubemap arrays allows the use of this OpenGL feature that the Environment Light requires.

 

General | Bindless Textures Allowed

checkbox

Enables the use of bindless textures for hardware that can support them.

This allows a greater number of textures to be used on a graphics card.

 

General | Vsync

dropdown

Sets the VSync option to Off, On, or System.

If the VSync option is On, then this forces the main canvas to only update at the monitor’s refresh rate. If it is Off, then the main canvas can update at any time. This could result in tearing, if the canvas is running faster than the monitor’s refresh rate.

If the option for System is set, Mari uses the system and driver settings for VSync. Mari needs to be restarted for this to fully take effect.

This setting is dependent on driver and operating system settings. Hence, this option doesn't appear if you do not have the correct OS or drivers.

Shaders | Use Cache

checkbox

If this is enabled, the preference uses already-compiled shaders a second time, otherwise Mari compiles every time shaders, nodes, or layer stacks are changed.

 

Shaders | Tessellation Allowed

checkbox

Enables the use of tessellation shaders for hardware able to support them.

 

Shaders | Compute Allowed

checkbox

Enables the use of compute shaders for hardware that can support them.

This can speed up rendering by pre-filtering data.

 

Shaders | Compilation Mode

dropdown

Specifies the strategy to use when compiling GLSL shader programs:

Legacy - uses the Optimized strategy with an older OpenGL technique for passing data into the shader. This matches how Mari operated prior to Mari 3.3v1.

Dynamic - compiles shaders less frequently and at a faster speed. This may decrease the FPS.

Optimized - compiles shaders more frequently and at a slower speed. This may increase the FPS.

Automatic - uses the Dynamic shader while the Optimized is being compiled.

 

Shadow Maps | Allowed

checkbox

Allows the use of shadow rendering in Mari. If the box is ticked, shadow-related features are available in the Lights and Objects palettes. By default, this preference is disabled.

Depending on your
hardware and project requirements, shadow
processing may cause a noticeable drop in UI
responsiveness.
Disabling this option
disables shadow
processing entirely and improves rendering
throughput.

Shadow Maps | Use
Variance Maths

checkbox

Sets whether variance map maths are used for shadows. If this box is ticked, the boundary of the shadows are softer and less prone to aliasing. For a sharper edge to shadows,
unselect this box.

If Allow Depth
Projections
is
unselected, shadows do not display. The Use Variance Maths
checkbox should be unselected as it depends on shadows being used.

Shadow Maps | Resolution

dropdown

Sets the texture resolution of each of the array of depth textures used for shadow rendering. The Depth
Projection Texture Array Size
is linked to this resolution and impacts other resolution sizes set in Mari.

 

Shadow Maps | Layer Count

dropdown

Sets the number of depth projection textures to use for shadow rendering. Increasing the array size increases the graphics card memory made available for shadow rendering. The total graphics memory used for these textures is 8 multiplied by the depth projection resolution, multiplied by the depth projection texture array size. The array size controls how many angles each light of the 4 lights uses. The maximum array size is 24, which allows for 6 angles per light.

Options are available for 25-32, but at this time Mari does not use these additional angles. Selecting options over 24 causes wasted cache space.

Virtual Texture | Type

dropdown

Sets the pixel type of the virtual
texture that Mari uses. Setting this to Half or Float gives more precision when painting or previewing displacement but requires significantly more GPU memory.

 

Virtual Texture | Resolution

dropdown

Sets the size of the virtual textures Mari uses. Larger sizes may give better results but require significantly more GPU memory.

 

Virtual Texture | Layer Count

entry box, slider

Controls the number of 2D texture layers used in the virtual texture Mari uses for display. Increasing this may resolve issues with flickering textures.

This value is dependent on the graphics card capabilities.

If you want to enable this preference for Mac OS X platform, go to the Environment Variables That Mari Recognizes section.

Virtual Texture | Bake Resolution

dropdown

Controls the size of the virtual
texture being used for the display. Increasing this setting may resolve issues, such as flickering, but takes up more memory.

This is a graphics card-dependent setting.

 

Virtual Texture | Gather Scale

entry box, slider

Sets the buffer size Mari uses when gathering information on which image tiles are required for rendering a scene. The default value of 1.000 halves the canvas resolution and works well in most situations, saving processing time. However, if glitches are appearing in the canvas, you may need to increase this value to fix the problem (at the cost of reduced painting and navigation speed).

 

Virtual Texture | Gather Type dropdown

The pixel format the virtual texture system uses to complete a 'meta' render, in order to verify which textures it needs during a full render. The formats are:

Short - a short/small integer value; 16 bits.

Float - a floating point value; 32 bits.

Note: With some Intel cards on Linux, the Short option does not always behave as it should, and it's recommended that you use Float.

Virtual Texture | Thin
Triangle Quality

entry box, slider

Controls the texture preview quality of thin triangles. The default value is 0. In cases where the geometry has long thin triangles, increasing this value results in the use of higher
resolution textures.

 

Misc. Tab

Setting

Type

What it does

Notes

Misc

Appearance | Use Custom Font Size

checkbox

Enabling this allows you to change the font used in Mari from the default setting.

 

Appearance | Custom Font Size

entry box, slider

Adjusts point size of the custom font.

Use Custom Font must be enabled in order for this to have an affect.

Appearance | Tool Bar Size entry box, slider Adjusts the tool bar sizes in Mari.  

Appearance | Slider Precision

entry box, slider

Adjusts how many decimal places are represented by Mari’s sliders.
Increasing this gives you finer control over slider values.

 

Appearance | Locator Size

entry box, slider

Adjusts the locator size on the canvas in Mari.

 

Import and Export| Remember Paths

checkbox

If enabled, Mari automatically
remembers paths previously set for importing and exporting, and offers them again next time you attempt to import or export.

 

Import and Export | Show Import Summary

checkbox

Sets whether Mari displays an import
summary dialog after importing an image.

The import summary
dialog displays
information such as how many images were imported, how long the operation took, and if patches were resized - then how many.

Input | Use Hi-Res Positions

checkbox

If this option is enabled, Mari uses high resolution position values from tablets and other devices.

Most often this is only noticeable using Paint and Vector Paint on large patch sizes.

In some cases, having this option enabled can hinder painting entirely. Disabling it resolves the issue.

Input | Zero Pressure Allowed checkbox Enabling this fixes any pressure issues you might experience with the Wacom Intuos 3. If you aren't experiencing any issues, don't enable this option, as it can introduce other problems under Windows 8.1.

Input | Use Mouse-Mapping Mode

checkbox

When using a tablet, determine whether or not to set your pen to behave as a mouse, so that positions are relative and incremental.

If this is enabled, you can access screen areas outside of your tablet's reach.

 

Named Files | Patch Cutoff

entry box, slider

Sets the maximum number of patches objects are allowed to have for the Named Files tab to appear on the Import and Export Channel dialogs. You can override this setting using the MARI_NAMEDFILEIMPORT_SEQUENCELIMIT environment
variable.

You can use the Named Files tab to import or export individual files rather than a sequence of patches with the UDIM number (1001, 1002, etc.) in the file names.

 

Scene | Default Lights Fixed To

dropdown

Sets whether the lights are fixed to a
camera or scene by default.

 

Shelf | Show Overlay

checkbox

Specifies whether to show object
information over the items within shelves (for example, color values for color swatches).

 

Shelf | Show Labels

checkbox

Specifies whether to show item labels in shelves (for example, names for color swatches).

 

Shelf | Shelves Include Presets

checkbox

Specifies whether to show Mari's preset shelves in the Shelf palette. If off, only the Menu, Personal, Project and custom shelves are displayed.

 

Shelf | Remake Icons

button

Regenerates Mari's icons for shelf items. If these have become corrupt (for example, if your brush icons are all blank), clicking this forces Mari to re-create all the icons.

 

Toggle Tools | Tool on Key Held

checkbox

Sets how the shortcut keys for the Zoom Paint Buffer (Z), Eye Dropper (C), and Select (S) tools work.

If On, these shortcut keys only apply while you're holding them down. Mari switches back to your previous tool when you let go of the shortcut key.

If this is Off, tapping the shortcut key quickly switches permanently to the tool, and holding it down for more than a second or two switches to the tool while you're holding the shortcut key (and switches back as soon as you let it go).

 

Toggle Tools | Key Held Threshold Time

entry box, slider

If Tool on Key Held is On, this property allows you to specify the time, in milliseconds, after which a key is considered to be held for tool toggling purposes.

 

Navigation Tab

Setting

Type

What it does

Notes

Navigation

General | Momentum Enabled

checkbox

If this is enabled, the model has momentum, so when you let go of the mouse button, it slowly coasts to a stop. If this is disabled, the model only moves when you are holding the mouse button down.

 

General | Minimum Flick Speed

entry box, slider

Sets the minimum speed at which you can move your model around. The higher this is set, the more
sensitive the movement controls are.

 

General | Friction

entry box, slider

Affects the momentum of your model as you move it around the
canvas.

Decreasing this value allows movement to retain its momentum for longer. Increasing the value arrests momentum faster.

General | Control Type

dropdown

Sets up the Mari controls on the
canvas to match the controls of another application, specified in the dropdown list. Applications include: 3ds Max, Houdini, Lightwave, Mari, Maya, Modo, and Nuke.

 

Orbit | Lock To World Up

checkbox

If this is on, it locks the y axis to world up view.

 

Orbit | Center Mode

dropdown

Specifies the center point to orbit around from the choice of:

Look At - what is currently being viewed in the display.

Objects - the objects in a scene.

Origin - the scene origin point.

Selection - the current selection.

 

Roll | Circular Motion Enabled

checkbox

If enabled, rolling is achieved by
making a circular motion in the
center of the canvas. If this option is disabled, rolling is only done with a horizontal motion across the canvas.

 

Node Graph Tab

Setting

Type

What it does

Notes

Node Graph

General |Use Cache for Bake

checkbox, reset

If enabled, Mari uses the cached result of a node/layer for baking process such as "Flatten", "Merge Layers" and "Bake to Paintable". Mari does not process layers below the cached layer or upstream nodes of the cached node, but uses the cached result.

For more information about caching nodes, see Working with Node Properties.

General | Control Type

dropdown

Set whether you want to zoom and pan in the Node Graph with the Mari or Nuke navigation style.

 

General | Default Port Display

dropdown

Allows you to specify how the node ports connect in the Node Graph. Nodes can be read from left to right or top to bottom.
You can select from the following navigation types:

  • Show Port List (Horizontal): Mari uses the left-to-right navigation.
  • No Port List (Vertical): Mari uses the top-to-bottom navigation.

Switching between these navigation types does not alter existing nodes, it only changes the nodes you create after having switched the navigation.

You can switch the navigation type of a selected node or multiple selected nodes by using Shift+S.

General | Auto Insert Node

checkbox, reset

If checked, when you drag a node over an existing pipe, Mari auto-inserts the node between nodes.

If unchecked, when you drag a node over an existing pipe, Mari does not auto-insert the node between nodes.

 

General | Zoom To

dropdown

Allows you to set whether to zoom according to the Cursor's position or the Center of the Node Graph.

 

Multi-Channel | Default Collapsed State dropdown Allows you to select a default collapsed state for Multi-Channel nodes to be displayed with in the Node Graph.  

Nuke Tab

Setting

Type

What it does

Notes

Nuke

General | Use Flat Lighting

checkbox, reset

Modifies the Nuke workflow to use flat lighting.

The reset icon resets the flat lighting option back to default.

Server | Nuke Host

entry box, reset

Allows you to specify the host name for the location of Nuke.

 

Server | Port

entry box, slider, reset

Allows you to specify the port number, or modify it with the slider.

 

Server | Nuke Launch Path

entry box

Allows you to browse and load a launch path for accessing Nuke files.

The path can be written manually or inserted using the browse and load icon.

Painting

Setting

Type

What it does

Notes

Painting

Cursor | Shape

dropdown

Allows you to set whether the brush cursor in Mari is displayed as an outline of the selected brush tip or as a standard round paint cursor.

 

Cursor | Opacity

entry box, slider

Allows you to set the opacity of the brush cursor. This only affects how opaque the cursor design is, not the opacity of the paint.

 

Projection | Default Color Depth

dropdown

Sets the default color depth Mari uses: 8, 16, or 32-bit.

 

Paths Tab

Setting

Type

What it does

Notes

Paths

Channel Presets | Search Paths

list, button

Adds or removes directories that Mari checks for channel preset
configuration files.

See the Mari User Guide for details on writing your own channel
preset files.

Environments | HDR Paths list, button

Adds or removes directories that Mari checks for environment light images.

For each directory provided, a Thumbnails sub-directory within it is looked for that should contain smaller versions of the images, with matching filenames, for use by the UI.

When Mari scans the path, it also searches for image thumbnails to use from the Thumbnails directory.

Materials | Ingest Template Paths

list, button

Adds or removes directories that Mari checks for .mma files to be used as material ingest templates.

Any found .mma files in the given paths appear in the Material Template dropdown of the Material Ingest Tool.

See Creating Materials with the Material Ingest Tool.

Any paths defined in the Ingest Template Paths can be overridden by the following environment variable: MARI_MATERIAL_INGEST_TEMPLATES_SEARCHPATHS.

Megascans| Search Paths

 

Adds the directory that Mari checks for Megascans assets.

See Texture Sets Palette.

Shaders | Search Paths

list, button

Adds or removes directories that Mari checks for compositing shaders.

 

Ptex Tab

Setting

Type

What it does

Notes

Ptex

Face Textures | Minimum Size

dropdown

Sets the minimum face texture size. The options provide increments in powers of two, and allow you to clamp face texture sizes during
project creation and face resizing.

The default state is 1 for
quadrangular textures, and 2 for triangular
textures.

Scripts Tab

Setting

Type

What it does

Notes

Scripts

Console | Font Size

entry box, slider

The point size of the default Mari font in the Python console.

 

Mari Command Port | Port

entry box, slider

Sets the port number that Mari receives commands from Nuke through. The default value is 6100.

 

Mari Command Port | Enabled

checkbox

If checked, Mari can receive commands through the specified port.

The default state is
disabled.

Mari Command Port | Local Host Only

checkbox

If unchecked, Mari can listen for connections to its command port from any machine.

If this is checked, then Mari only listens for connections from the local machine.

Only allowing connections from the local host is more secure but
prevents you from using features, such as the Nuke<>Mari Bridge.

The default state is enabled.

Thumbnail Tab

Setting Type What it does Notes
Geo-Channel Properties
Channels button Adds a new geo-channel to the mesh object defined in Mesh File. The geo-channel drives defined mesh maps such as ambient occlusion, and curvature into the object in the exported material thumbnail.  
button

Imports an image set to the geo-channel.

Note:  If the imageset was produced using the Modo Bake Presets, information about the bake preset is displayed in a tooltip when hovered over the imageset.

 
button Resets the imageset assigned to the geo-channel.  
button Removes the geo-channel.  
Scene
Mesh File entry box, button Specifies the mesh file to be used in generating material thumbnails during material export.  
Env Light File entry box, button Specifies the environment light to be used in generating material thumbnails during material export.  
Projector File entry box, button Specifies the projector to be used in generating material thumbnails during material export.