Flix for Story

This page covers how Flix works with Photoshop and Storyboard Pro.

The video below provides an overview of how Flix and Photoshop work together.

 

Importing Panels into Flix

You can import panels and other file formats using the file browser or by dragging directly into Flix.

1.   In the main toolbar, click the Import to Flix button.

This opens a file browser.

2.   Select one or multiple files.

Note:  You can import the following files: .png, .psd, .jpeg, .jpg, .mov, .mp3, .ogg, .tiff and .wav.

Warning:  Imported .psd files from Sketchbook Pro are not supported. For information on workarounds, see this Knowledge Base Article.

3.   Click Open.

OR

From your file browser, drag one or more files directly into the Flix Panel Browser. You can also drag folders into the Panel Browser for Flix to import their contents.

Your files are imported in the sequence.

Note:   Flix keeps track of every imported image and reuses an existing panel instead of creating a new one. In cases where you need to reimport images that have been worked on previously, Flix recognizes which images it's seen before and only process the new ones.

When audio, such as .mp3 or .wav files are imported, Flix displays an audio icon in the Status bar.

Note:  If you import a .mov file to the panel browser, any embedded audio contained in the file is not retained. Please see Flix for Editorial for details on importing movie files from editorial with audio.

Making Changes to the Edit

In Flix, you'll be working primarily in the Panel Browser. The following video gives a brief overview of how to navigate and work with your sequence in the Panel Browser.

In the video:

Importing panels. For more information, please refer to Flix for Story.

Each panel displays a unique Panel ID and Index, or position number. If the panel has been updated, a new version is created and numbered.

Note:  You can swap the position of each panel's unique ID with its Index number. See Swap Panel ID with Index in Preferences.

Move panels around by selecting one or more, and dragging them where you want to place them. Hold Shift and click to select a sequence of panels, or Ctrl/Cmd and click to select individual panels.

Remove panels from your current edit by clicking the Trashcan icon in the Edit toolbar.

Re-use panels by using the Copy and Paste buttons in the Edit toolbar. This creates new panels re-using the same panel, timing, and dialogue.

Using the annotation tool. For more information, see Annotations.

Adding and versioning dialogue.

Tip:  Duplicate selected panels with the Duplicate button.

Editing Panels Already in Flix

To make changes to panels in your edit (sequence revision), you can open and edit them in third-party applications. See the Flix & Photoshop section.

Adding or Editing Dialogue

You can easily add dialogue to your panels in both the Story and Dialogue workspaces. Dialogue is displayed as subtitles in the Player, which you can turn on and off.

Method 1

Flix's Story workspace (default) contains the Dialogue controls in the Panel Properties pane in the Dialogue tab.

To add and edit dialogue:

1.   Select the required panel and enter text in the Dialogue box. Press Enter to add new lines.

This adds dialogue to the selected panel, which is displayed as subtitles in the Player.

Note:  If you select multiple panels, the same dialogue is added to all selected panels.

2.   Use the Dialogue tools to modify the formatting of your text.
3.   Click the Toggle Subtitles button to turn the subtitles on and off. Click and hold on the button to display the text size slider control.

Tip:  Use the Undo and Redo buttons, located under the breadcrumb, to undo or redo your recent actions.

4.   Click Save to save all new dialogue.
5.   Keep track of the dialogue history by clicking on the Dialogue History dropdown menu.

Method 2

In the Story workspace at the top-right corner, click the Switch Workspace button and select Dialogue workspace. The Dialogue workspace contains a Panel Browser and a Dialogue pane.

To add and edit dialogue:

1.   Select the required panel and enter text in the Dialogue box. Press Enter to add new lines.

This adds dialogue to the selected panel.

Note:  If you select multiple panels, the same dialogue is added to all selected panels.

Tip:  Press Tab to move to the next panel and Shift+Tab to move to the previous panel when entering dialogue on the Dialogue workspace.

2.   Use the Dialogue tools (Bold, Italics, Underline, and Strikethrough) to modify the formatting of your text.

3.   Save your sequence revision to save all new dialogue.

Note:  Keep track of the dialogue history by clicking on the Dialogue History dropdown menu.

Annotations

You can annotate your panels directly in the Player, which is located at the top-right corner of the application in the Story workspace.

Note:  To add an annotation to a panel using Photoshop, refer to Annotating a Panel Using Photoshop.

1.   In the Panel Properties pane, toggle the annotations on by clicking the Pencil button at the bottom of the Player.

2.   Click the Color Palette button then click again to select a color.
3.   Click and hold the Pencil button then drag the slider to adjust the thickness of the pencil.
4.   Make annotations on your panel.
5.   Use the Eraser tool to partially erase your annotations or use the Trash tool to completely remove the annotations.

Annotated panels are tagged with the pencil icon and display a border around the thumbnail.

6.   To display only panels containing annotations, click the filter button and enable the Annotations filter.

Tip:  By default, annotations appear as an extra layer in PSD files open in Photoshop. You can disable this by going to File > Preferences > Third Party Apps > Adobe Photoshop and disabling the Send Annotation as Layer preference.

Panel Comments

You can add comments to individual panels, which allows Flix users to create a feed of notes and feedback on a sequence. Any comments written on a panel are flagged, so you can see at a glance which boards require attention.

To add a comment:

1.   Click on Comments under the Player.
2.   Type your comment into the Comment window and press Enter to post it.

The panel on which you've commented now displays a comment icon. Hover over the icon to see the latest open comment.

Your comment appears in a feed with any other comments other users have added to that panel.

Every comment has a checkbox which allows users to mark as resolved. For example, once feedback in a comment has been addressed, the person approving the change would tick the comment so everyone in the production knows that feedback has been actioned.

Note:  Once all the comments in a feed have been resolved, the comment icon disappears from the panel.

Filtering a Sequence by Comment

You may want to quickly filter your sequence to display only panels with open comments made on them.

To filter by comment:

1.   Click on the filter icon in the panel browser.
2.   Select Commented.

Flix displays only panels with open comments on them.

Recording a Pitch

Periodically, you may want to pitch sequences to others involved in the project to present your work. Pitching allows you to do a rough timing for your sequence, for example depending on the action you may want to stay longer on one panel.

You can access the Pitch workspace through the Player in the Panel Properties pane.

1.   If you want to record audio while pitching, navigate to File > Preferences > Audio and select an Input Device. If you already have audio in your sequence and don't want to override it, in the Player click the Microphone button to disable it.

Note:  When pitching with audio, use the Volume button to make sure the volume is set properly.

Tip:  You can switch to Full Screen mode by clicking the Full Screen button. Press Esc to exit the Full Screen mode.

2.   Click the Record button to start pitching.

In the red bar at the top of the Player, the Time and the Duration timers are running.

3.   As soon as you reach the required duration, press the right arrow key to move to the next panel.

By switching to the next panel, you stop the recording of the duration for the current panel and start the recording for the next one.

4.   Keep recording the duration for each panel until the end of the sequence or click the Record button again to stop recording.

In the Panel Properties pane, select the Properties tab to check the updated duration for your panels. You can also change the duration in the Properties tab directly by entering a new duration or using the arrows.

Tip:  When playing the sequence, press A to add an audience at the bottom of your panels.

Flix & Photoshop

The following video provides an overview of how Flix and Photoshop work together.

 

Setting Up Flix to Work with Photoshop

To use Photoshop with Flix, you first need to select Photoshop as your sketching tool then set up the required version and install the plug-in.

1.   Ensure Photoshop is closed while setting preferences in Flix.
2.   Navigate to File > Preferences > Third Party Apps.
3.   In the Sketching tab, select Photoshop.
4.   In the Photoshop tab:

set the Executable preference by browsing to the version of Photoshop you want to use with Flix.

set the Panel Open Behavior:

Open as Separate PSD - Opens the selected panels in Photoshop as separate .psd files.

Open in Layer Comps - Opens the selected panels in Photoshop as layer comps.

Open in Timeline - Opens the selected panels in Photoshop in the Timeline.

enable or disable Always Open Master Image - This opens the .psd file in Flix as a master image, which means that all information is saved, such as hidden layers and empty groups.

enable or disable Send Annotation as Layer - This option sets annotated panels to open in Photoshop with their annotations shown on an additional layer.

click Install Plugins. This installs the Photoshop scripts to run the Photoshop actions.

Note:  Installing the Photoshop plug-in may require admin privileges. Ask your system administrator for assistance, as they can install these manually if needed. Steps for this can be found in Manually Installing the Photoshop Plugin for End Users.

5.   To open the Photoshop actions, in Photoshop, navigate to Window > Extensions > Flix.

The Photoshop Actions open in a new tab called Flix.

Assigning Keyboard Shortcuts to Flix Commands

From Flix 6.3.3 onwards you can assign keyboard shortcuts or 'hotkeys' to the list of Flix commands in Photoshop. The video below shows you how.

Note:  If you do not have administrator privileges, you will need to contact your IT department to help you with the following steps.

To set up Flix keyboard shortcuts in Photoshop:

1.   In Photoshop, click the hamburger menu on the Flix toolset.
2.   Select Enable Flix Hotkeys.

An alert with instructions appears and two windows open automatically.

3.   Click OK to close the alert.
4.   Copy the Flix 6 Hotkeys folder from the temp directory to the Scripts folder in Photoshop's directory.

Note:  We recommend copying rather than cutting or moving the Flix 6 Hotkeys folder from the temp directory. If you mistakenly delete or misplace the folder, restart the process from step 4, and the folder is recreated in the temp directory.

5.   Restart Photoshop.

You can now assign keyboard shortcuts to Flix commands in Photoshop. If you're already familiar with assigning keyboard shortcuts in Photoshop, you can skip the rest of these steps.

6.   In Photoshop, navigate to Edit > Keyboard Shortcuts...

The Keyboard Shortcuts and Menus window opens.

7.   In the Application Menu Command column, expand the Filesection and scroll down to the Scripts subsection.

8.   Click on a Flix command to add a shortcut. Click Accept once you've entered the shortcut commands you want to use.

Note:  If you assign a shortcut to a pre-existing one, Photoshop alerts you to a conflict. You can overwrite the original shortcut with your new one by clicking Accept, or click Accept and Go to Conflict to assign a new shortcut to the pre-existing one.

9.   Click OK to close the Keyboard Shortcuts and Menus window.

Tip:  You can check the scripts that have been installed in Photoshop by going to File > Scripts. Any assigned hotkeys are also listed here.

Creating a New Panel and Sending it to Flix

1.   In Photoshop, in the Flix tab, select the aspect ratio at the top of the list to match the one of your show.

Note:  Select whether you want to Always Send Original as Master. This sends the original file, unedited, as a Master file to Flix. This does not insert anything in the edit (sequence revision).

2.   Select New Template.
3.   Draw on the panel.
4.   Select Current Image.

Flix sends the panel to the edit (sequence revision). The panel is inserted after the currently selected panel

Creating Thumbnails and Sending them to Flix

1.   In Photoshop, open the Flix tab and select the aspect ratio at the top of the list to match the one of your show.

OPTIONAL: Select whether you want to Always Send Original as Master. This sends the original file, unedited, as a Master file to Flix. This does not insert anything in the edit (sequence revision).

2.   Click New Thumbnails.
3.   Draw on the thumbnails.
4.   Click Send Thumbnails.

Flix sends the thumbnails to the edit. The thumbnails are inserted as nine new individual panels after the currently selected panel, if any.

Note:  Make sure the File > Preferences > Always Open Master Image preference is disabled, otherwise when you open one of the nine thumbnails from Flix to Photoshop it will open the original panel containing the nine thumbnails.

Annotating a Panel Using Photoshop

1.   In Flix, select a panel in your edit and click the Open in Sketching App button.

The panel opens in Photoshop.

2.   In Photoshop, select the layer you wish to annotate. You may want to create a new layer.
3.   Draw an annotation on the layer.
4.   In the Flix toolbar, click Selected Layer as Annotation.
5.   In Flix, click the annotations button under the player to display the new annotation.

Working with Flix and Photoshop's Layer Comps

OPTIONAL: Select whether you want to Always Send Original as Master. This sends the original file, unedited, as a Master file to Flix. This does not insert anything in the edit (sequence revision).

In Photoshop, with your .psd file open, open the Flix tab and click Each Layer Comp or Selected Layer Comp.

Photoshop sends to Flix each (selected) layer comp as a single panel.

Making Revisions to Layer Comps

If a master image is available for your layer comps:

1.   Ensure the File > Preferences > Third Party Apps > Photoshop > Always Open Master Image is enabled.
2.   Select the panel you want to work on.
3.   In the main toolbar, click the Open in Sketching app button.

In Photoshop, this opens the master image with all information including hidden layers and empty groups.

In Flix, this opens the Master file that the panel is linked to in Photoshop.

4.   After you are done working on your master image, save the .psd file and select Replace Each Layer Comp from the Photoshop actions.

In Flix, this updates panels from the first selected to the last, going from the first layer comp to the last.

This video demonstrates how Master Images are created and where Flix stores them.

OR

If you haven't started your work with layer comps or don't have a master image:

1.   Navigate to File > Preferences > Third Party Apps > Photoshop > Panel Open Behavior and select Open in Layer Comps.
2.   In your edit (sequence revision), select the required panels you want to open as layer comps.
3.   In the main toolbar, click the Open in Sketching app button to send your panels to Photoshop.

This opens one .psd file containing a layer comp for each selected panel, each layer comp containing the layers associated to the selected panels.

4.   After you are done working on your layer comps, save the .psd file

This automatically replaces the opened panels with the updated layer comps.

Working with Flix and Photoshop's Frame Timeline

Note:  Select whether you want to Always Send Original as Master. This sends the original file, unedited, as a Master file to Flix. This does not insert anything in the edit (sequence revision).

In Photoshop, with your .psd file open, open the Flix tab and click Each Frame.

Photoshop sends each frame in the Frame Timeline to Flix as a single panel.

Making Revisions to Frames

If a master image is available for your frames:

1.   Ensure the File > Preferences > Third Party Apps > Photoshop > Always Open Master Image is enabled.
2.   Select the panel you want to work on.
3.   In the main toolbar, click the Open in Sketching app button.

In Photoshop, this opens the master image with all information including hidden layers and empty groups.

In Flix, this opens the Master file the panel is linked to in Photoshop.

4.   After you are done working on your master image, save the .psd file and select Replace Each Frame from the Photoshop actions.

In Flix, this updates panels from the first selected to the last, going from the first frame to the last.

OR

If you haven't started your work with frames or don't have a master image:

Note:  When you are working in a Frame Timeline without any original master image, in the Frame Timeline, click the Hamburger button and disable New Layers Visible in All Frames. This displays all the frames in the Frame Timeline, otherwise all the panels are the same.

1.   Navigate to File > Preferences > Third Party Apps > Photoshop > Panel Open Behavior and select Open in Timeline.
2.   In your edit (sequence revision), select the required panels you want to open in a timeline.
3.   In the main toolbar, click the Open in Sketching app button to send your panels to Photoshop.

This opens one .psd file containing one frame for each selected panel, each frame containing the layers associated to the selected panels.

4.   After you are done working on your frames, save the .psd file

This automatically replaces the opened panels with the updated frames.

Working with Flix and Photoshop's Layers/Groups

OPTIONAL: Select whether you want to Always Send Original as Master. This sends the original file, unedited, as a Master file to Flix. This does not insert anything in the edit (sequence revision).

In Photoshop, with your .psd file open, open the Flix tab and click any of the following:

Note:  Make sure the layers or groups you want to send are visible otherwise they will be ignored.

Each Layer - Sends to Flix each visible layer in an image as a separate panel.

Each Layer + BG - Sends to Flix each visible layer in an image as a separate panel but keeps the background the same for each one.

Each Layer + FG/BG - Sends to Flix each visible layer in an image as a separate panel but keeps the background and foreground the same for each one.

Selected Layer(s) - Sends to Flix only the selected layers of the image as a new panel.

Making Revisions to Layers and Groups

If a master image is available for your layers:

1.   Ensure the File > Preferences > Third Party Apps > Photoshop >Always Open Master Image is enabled.
2.   Select the panel you want to work on.
3.   In the main toolbar, click the Open in Sketching app button.

In Photoshop, this opens the master image with all information including hidden layers and empty groups.

In Flix, this opens the Master file the panel is linked to in Photoshop.

4.   After you are done working on your master image, save the .psd file and select any layer actions (see above) from the Photoshop actions.

In Flix, this updates panels from the first selected to the last, going from the first layer or group to the last.

OR

If you haven't started your work with layers or groups or don't have a master image:

1.   Navigate to File > Preferences > Third Party Apps > Photoshop > Panel Open Behavior and select Open as separate PSD.
2.   In your edit (sequence revision), select the required panels you want to open as layers or groups.
3.   In the main toolbar, click the Open in Sketching app button to send your panels to Photoshop.

This opens one .psd file containing a layer or group for each selected panel, each layer or group containing the layers associated to the selected panels.

4.   After you are done working on your layer comps, save the .psd file

This automatically replaces the opened panels with the updated layers or groups.

Flix & Storyboard Pro

Setting Up Flix to Work with Storyboard Pro

To set Storyboard Pro as your Sketching Tool:

1.   Navigate to File > Preferences > Third Party Apps > General.
2.   In the Sketching tab, select Storyboard Pro from the dropdown menu.
3.   In the Storyboard Pro tab:

Set the Executable preference by browsing to the StoryboardPro (.exe on Windows, .app on Mac) executable file on your computer. The file path should look something like this: C:\Program Files\Toon Boom Animation\Toon Boom Storyboard Pro 6\StoryboardPro.exe.

Under the Import section, choose the behavior for importing Storyboard Pro project files containing Camera Moves:

Hold First Frame - Holds the first frame to render a still panel.

Render All Frames - Renders all the frames to create an animated panel.

Note:  Hold First Frame imports are quicker than imports with Render All Frames set. Storyboard Pro exports PSDs for each panel, which Flix renders on import. If the animation of a panel is not required, choose Hold First Frame, as Flix will only render one frame per panel rather than all frames.

Under the Export section, choose the behavior for exporting Flix sequences to Storyboard Pro.

Export Path - Set the path for your exported Flix sequence.

Export Dialogue - Toggle ON to update dialogue in Storyboard Pro.

Export Camera Moves - Toggle ON to update Camera Moves in Storyboard Pro.

Export Audio - Toggle ON to include audio from Flix in exports to Storyboard Pro.

Export Markers - Marker updates are not currently supported in Storyboard Pro.

Importing Storyboard Pro Projects into Flix

You can create a new sequence revision by importing your Storyboard Pro project directly into Flix.

To import your Storyboard Pro project into Flix:

1.   Save your Storyboard Pro project.
2.   In Flix, navigate to the Revisions page, either by clicking on your sequence or creating a clean version.

3.   Click on the SBP Import button.

The Storyboard Pro Import page opens.

Note:  If Storyboard Pro is not installed on the machine running Flix client or has not been set in your Preferences, the SBP Import button is disabled.

4.   Click Browse and navigate to the Storyboard Pro project (.sboard) file you want to import. Select the file and click Open.

The path to the project file appears in the Project Path.

5.   Enter a comment if you want it to appear on the new sequence revision, then click Import.

Flix reports that the import was successful.

Note:  Depending on the size of the project file, the import might take a few moments.

6.   Click on Sequence in the breadcrumb to return to the Revisions page.

A new sequence revision has been created from your Storyboard Pro import.

Note:  If markers are set to display in the panel browser, scene numbers show as markers on sequences imported from Storyboard Pro.

Exporting Flix sequences to Storyboard Pro

To open your Flix sequence in Storyboard Pro:

1.   Ensure Storyboard Pro is the default sketching tool. To check this, please read Setting Up Flix to Work with Storyboard ProSetting Up Flix to Work with Storyboard Pro
2.   Open the sequence revision you want to send to Storyboard Pro.
3.   Click on the Open in Sketching App button, or double-click on a panel.

Flix confirms if you want to send the selected sequence to Storyboard Pro.

4.   Click Export.
5.   Flix creates a .xml file and saves it in the location nominated in your exports path.

Note:   To change the default path for exports, go to File > Preferences > Third Party Apps > Storyboard Pro > Export.

Re-conforming Your Project in Storyboard Pro

When changes come back from editorial and Flix, you can always update your project in Storyboard Pro and continue working. First, you will need to reconform your original Storyboard Pro project, following these steps.

1.   In Storyboard Pro, go to File > Conformation > Import Animatic Project.

The Import Project menu opens.

2.   Enter the path to the .xml file exported from Flix, or click the icon and browse for the file. Once located, click Open.

Tip:  You can copy the path from the Export to Storyboard Pro menu in Flix and paste it in the Import Project menu. See Exporting Flix sequences to Storyboard Pro for more information.

3.   Click Import.

Storyboard Pro asks for confirmation of the sequence you are importing. You may see a warning that the project name is different to the file being imported. This is expected, as Flix is likely to have been set up with export naming conventions.

4.   Click Okay.

Your Storyboard Pro sequence updates with any changes that came from Flix.