ノードグラフ関数

ノードグラフで使用できる関数のリストは、以下の表にあります。

関数

アクセス方法

それがすること

このダイアログボックスを開きます

ノート

ペイントノードを追加

• Right-click |ノードグラフ>ペイントノードの作成

• キーボード | P

画像セットを追加するためのダイアログボックスを開きます。

ペイント/ベイクポイントダイアログの追加

 

グループノードを追加

• Right-click |ノードグラフ>グループ

• キーボード | Ctrl/Cmd+G

選択したノードを含むグループノードを作成するか、ノードが選択されていない場合は空のグループを作成します。

 

 

画像をペイントノードにインポートする

• Right-click |ノードグラフ>ファイル>インポート

ディスク上のイメージを現在のノードグラフで選択されたペイントノードにインポートします。

 

 

ペイントノードから画像をエクスポート

• Right-click |ノードグラフ>ファイル>エクスポート

選択したペイントノードを現在のノードグラフからディスク上のファイルにエクスポートします。

 

 

ノードをノードグラフにインポートする

• Right-click |ノードグラフ>ファイル>ノードのインポート

選択したノードを現在のノードグラフにインポートします.mngファイル。

 

 

ノードグラフからノードをエクスポートする

• Right-click |ノードグラフ>ファイル>ノードのエクスポート

選択したノードを現在のノードグラフから.mngファイル。

 

 

ノードグラフからチャネルノードをエクスポートして平坦化する

• Right-click |ノードグラフ>ファイル>フラット化されたすべてのチャネルノードをエクスポート

各パッチをすべてのチャンネルノードの単一のイメージとしてフラット化し、それらを一連のファイルにエクスポートします。

 

 

ノードグラフから選択したチャンネルノードをエクスポートして平坦化する

• Right-click |ノードグラフ>ファイル>フラット化された選択したチャネルノードのエクスポート

選択したチャンネルノードの単一のイメージとして各パッチをフラット化し、それらを一連のファイルにエクスポートします。

 

 

選択したノードをクリップボードにコピー

• Right-click |ノードグラフ>編集>コピー

• キーボード | Cmd/Ctrl+C

選択したノードを現在のノードグラフからOSのクリップボードにコピーします。

 

 

ノードをクリップボードから貼り付け

• Right-click |ノードグラフ>編集>貼り付け

• キーボード | Cmd/Ctrl+V

OSクリップボードから現在のノードグラフにノードを貼り付けます。

 

 

選択したノードを複製

• Right-click |ノードグラフ>編集>複製

現在のノードグラフで選択したノードの複製を作成します。

 

 

ペイントをペイントノードにベイクする

• Right-click |ノードグラフ>編集>ノードをペイントしてベイク

選択したノードをペイントノードに変換し、その出力をエクスポートできるようにします。

 

 

選択したノードの名前を変更

• Right-click |ノードグラフ>編集>ノード名の変更

• キーボード | N

選択したノードの名前を変更します。

 

 

選択したノードを無効にする

• Right-click |ノードグラフ>編集>無効化

• キーボード | D

選択した1つまたは複数のノードを無効にし、優先入力のみをノードツリーに渡します。

 

 

選択したノード入力をバイパスする

• Right-click |ノードグラフ>編集>バイパス

• キーボード | Ctrl/Cmd+D

ノードの入力を循環して、1つを除くすべてをバイパスします。

 

 

選択したノードを削除します

• Right-click |ノードグラフ>編集>削除

• キーボード | Del

選択したノードを現在のノードグラフから削除します。

 

 

ノードを抽出する

• Right-click |ノードグラフ>編集>抽出

• キーボード | Ctrl/Cmd+Shift+X

選択したノードを、接続しているノードから切り離します。

 

一度に抽出できるノードは1つだけです。

ノードを検索

• Right-click |ノードグラフ>編集>ノードの検索

• キーボード | J

ノードグラフで使用されているノードを検索し、それらにジャンプします。

 

 

ベイクポイント

• Right-click |ノードグラフ>編集>ポイントのベイク(Node Graph> Edit> Bake Points)

• 選択を更新

• ダウンストリームを更新

• スマートベイクとアップデート

• 選択したベイク

• 選択したベイクポイントノードを更新します。

• 選択したベイクポイントノードと下流にあるノードを更新します。

• ベイクされたことがないか、古くなっているベイクポイントノードをベイク処理します。

• 選択したベイクポイントノードをベイクします。

   

団体

Right-click |ノードグラフ>編集>グループ>

• ユーザーノブの管理

• ノードプロパティの公開

• を開きますGroup Node Knobsダイアログ。

• 選択したノードのすべてのプロパティをグループに公開します。

 

 

ポートリストなしとポートリストの表示を切り替えます

• Right-click |ノードグラフ>編集>ポートリストの切り替え

• キーボード | Shift+S

切り替えNo Port List (Vertical)そしてShow Port List (Horizontal) ナビゲーションタイプ。

見るMari設定ダイアログ詳細については。

 

 

情報ビューア

• Right-click |ノードグラフ>編集>情報ビューア

• キーボード | I

選択したノードに関する情報を表示します。

 

 

ノードを追加

• Right-click |ノードグラフ>ノード>カテゴリ>ノード

• キーボード | Tab

現在のノードグラフのカーソル位置または選択したノードの後にノードを追加します。

 

ノードの作成に加えて、シェーダーネットワークを作成することもできます。これは、 シェーダーパレット。

選択したノードを自動配置

• Right-click |ノードグラフ>自動配置

• キーボード | L

明確にするために、現在のノードグラフ内のすべての(または選択した)ノードを再配置します。