Contact Support

Common Parameter Widgets

These widget groups are common to many nodes in Katana and are outlined here. For more information regarding the addition of user parameters and specific widget types, refer to Widget Types and Adding User Parameters.

Asset and File Path Widget Types

The Asset (assetIdInput) and File Path (fileInput) widget types allow you to navigate to assets and files on your file system. Several node types that ship with Katana use the Asset and File Path widget types for parameters of various names, for example: abcAsset, file, filePath, lookfile, procedural, saveTo, and source.

Parameters that use the Asset and File Path widget types can be found on the following types of nodes:

Alembic_In

LookFileGlobalsAssign

AttributeFile_In

LookFileMaterialsIn

CameraImagePlaneCreate

LookFileMaterialsOut

GafferThree

LookFileMultiBake

ImageCoordinate

LookFileOverrideEnable

ImageRead

Material

LiveGroup

RendererProceduralArgs

LiveGroupStack

RenderOutputDefine

LookFileAssign

ScenegraphXml_In

LookFileBake

 

 

Menu Command

Description

Browse...

Brings up the file browser or your studio's asset management browser and enables you to select the asset to use.

Set Node Name From Path

Changes the name of the node to match the filename but without the path or extension.

CEL Statement Widget Type

The CEL Statement (cel) widget type allows you to build and edit CEL statements that are stored in string parameters on nodes. Several node types that ship with Katana use the CEL Statement widget type for parameters of various names, for example: CEL, cel, toCel, fromCel, celSelection, disableAt, exclusivity, lights, objects, off, and on.

Parameters that use the CEL Statement widget type can be found on the following types of nodes:

AttributeCopy

LightLink

Prune

AttributeEditor

LightLinkEdit

RendererProceduralArgs

AttributeFile_In

LightLinkSetup

RendererProceduralAssign

AttributeSet

LocationGenerate

ReverseNormals

AttributeUpgrade

LodSelect

ScenegraphObjectSettings

CollectionCreate

LodValuesAssign

VelocityApply

GafferThree

LookFileAssign

ViewerObjectSettings

GenericOp

Material

VisibilityAssign

 

OpScript

 

 

Menu Command

Description

Add Statements

Paths - Adds a Paths list to this CEL parameter.

Collections - Adds a Collections list to this CEL parameter.

Custom - Adds a Custom parameter to this CEL parameter.

Append Scene Graph Selection - Adds a Paths list to this CEL parameter and places selected scene graph locations in the new list.

Replace With Scene Graph Selection - Removes any parameters within this CEL parameter and creates a new Paths list and populates it with any selected scene graph locations.

Copy CEL Statement As Text - Copies this CEL statement to the clipboard.

Paste CEL Statement - Removes any parameters within this CEL parameter and pastes the CEL statement in the clipboard to this parameter.

Replace With Parameter Expression - Converts the current CEL parameter into an expression.

Paths > Action

Add Scenegraph Selection

Adds the currently selected scene graph location to this list.

Remove Scenegraph Selection

Removes the currently selected scene graph location from this list.

Remove Selected Paths

Removes the path(s), selected in this Paths list, from this list.

Select All

Selects all the paths in this list.

Select Selected Paths In Scenegraph

Selects the scene graph locations of the selected paths in this list.

Copy Selected Paths to Clipboard

Copies the selected paths from this list to the clipboard.

Show Extended View...

Brings up a dialog with the contents of this Paths list.

Collections > Action

Add Collections From Scenegraph Selection...

Brings up a dialog box with a list of the collections from the currently selected scene graph locations. You can then select from these collections to add them to this list.

Add Scene Root Collections...

Brings up a dialog box populated with the collections currently on /root. You can then select from these collections to add them to this list.

Remove Selected Paths

Removes the selected collection(s) from this list.

Select All

Selects all the collections in this list.

Copy Selected Paths to Clipboard

Copies all the selected collections and their paths to the clipboard.

"Find And Select" Selected Items...

 

Union dropdown

Union

Difference

Intersect

Does not occur in all nodes with CEL widgets. Only occurs on additional statements added to the widget after an initial statement.

Color Widget Type

The Color (color) widget type allows you to pick a color by specifying RGB or RGBA component values directly in the Parameters tab, or through a color picker dialog. Several node types that ship with Katana use the Color widget type for parameters of various names, for example: bottomLeft, bottomRight, color, constantColor, fadeToColor, gamma, and previewColor.

Parameters that use the Color widget type can be found on the following types of nodes:

GafferThree

ImageColor

ImageRamp

ImageBackgroundColor

ImageClamp

ImageText

ImageChannels

ImageContrast

ImageThreshold

ImageCheckerboard

ImageFade

LightCreate

 

ImageGamma

ViewerObjectSettings

 

ImageInvert

 
 

ImageLevels

 

 

Menu Command

Description

color

The color (RGBA values) for the given parameter.
Picks the color (RGBA) values of the selection.
>
Average Sets the color picker to use the average values.
Min Sets the color picker to use the minimum values.
Max Sets the color picker to use the maximum values.
Front Sets the color picker to use the front values.
Back Sets the color picker to use the back values.
Auto-Disable Upon Release Toggle the ability to automatically disable the picker on mouse-button release.

color > RGB

red

Sets the red value of the pixels.

green

Sets the green value of the pixels.

blue

Sets the blue value of the pixels.

alpha

Sets the alpha value of the pixels.

color > HSL

hue

Sets the hue of the pixels.

saturation

Sets the saturation of the pixels.

lightness

Sets the lightness of the pixels.

alpha

Sets the alpha value of the pixels.

color > HSV

hue

Sets the hue of the pixels.

saturation

Sets the saturation of the pixels.

value

Sets the value of the pixels.

alpha

Sets the alpha value of the pixels.

color options continued

Enable Display Transform Toggles gamma correction in the color picker, which is especially useful when working with OCIO.
Restrict RGBA Components Restricts the alpha to 0,1 and the color channels to 0,a.

Common 2D Node Widget Type

The Common 2D Node (node2d) widget type allows you to pick channels that are affected by a particular 2D node and specify masking parameters. This widget type is not exposed for use as a custom user parameter.

The Common 2D Node widget type can be found in each Image node, except for Image BackgroundColor, ImageChannels, ImageCheckerboard, ImageColor, ImageCoordinate, ImageCrop, ImagePixelStats, ImageRamp, ImageRead, ImageText, and ImageWrite.

Note:  Not all of the Image nodes have the Mask parameter.

Menu Command

Description

[view]

Specify whether the controls are set for the main, left, or right views, or set the controls to Enable All.

When a specific component (R, G, B, or A) is enabled, the controls affect only that component.

mix

Dissolves between the bg image at 0 and the full merge effect at 1.

Mask
channel

The channel from the out_mask input to use as a mask:

R - use the red channel as the mask.

G - use the green channel as the mask.

B - use the blue channel as the mask.

A - use the alpha channel as the mask.

By default, the merge is limited to the non-black areas of the mask.

invert Inverts the use of the mask channel so that the merge is limited to the non-white areas of the mask.
fringe

When enabled, the mask is modified so that, by default, the merge is limited to the fringe (semi-transparent areas).

This is common alpha treatment, which modifies a normal mask such that it only affects the fringe (semi-transparent) areas.

New Scene Graph Location Widget Type

The newScenegraphLocation (newScenegraphLocation) widget type allows you to specify the path of a scene graph location that is to be created by the respective node. It is used, for example, for the name parameter of CameraCreate nodes.

This widget type is not exposed for use as a custom user parameter, but can be accessed by setting the widget type hint to newScenegraphLocation. Several node types that ship with Katana use the newScenegraphLocation widget type for parameters of various names, for example: location, locations, and name.

Parameters that use the newScenegraphLocation widget type can be found on the following types of nodes:

Alembic_In

PonyStack

CameraCreate

PrimitiveCreate

ImageCoordinate

ScenegraphXml_In

LightCreate

TeapotCreate

 

Menu Command

Description

Parent to Scenegraph Selection Sets the parent location of the object created to be the current scene graph selection.
Parent to /root/world/geo/... Sets the parent location of the object created to be /root/world/geo/.
Parent to /root/world/lgt/... Sets the parent location of the object created to be /root/world/lgt/.
Parent to /root/world/cam/... Sets the parent location of the object created to be /root/world/cam/.
Select In Scene Graph

Selects the location specified by this parameter in the Scene Graph tab.

Note:  This option may be included in both the dropdown menu and as an icon to the right of the parameter name, or may only be present in one of these locations.

Locations Widget Type

The Locations (locations) widget type allows you to select scene graph locations by paths or expressions. It is not an exposed widget type for use as a custom user parameter. Out of all node types that ship with Katana, only Isolate nodes use the Locations widget type, namely for their isolateLocation parameter.

Menu Command

Description

Path

Adds another path to this parameter's list of paths.

Expressions  

Append Scene Graph Selection

For each selected scene graph location, a new path is added to this parameter's list of paths and populated with the location.

Replace with Scene Graph Selection

Removes all existing paths and replaces them with paths populated with the currently selected Scene Graph tab locations.

Append Node Graph Node Locations

For each selected Node Graph node, a new path is added to this parameter's list of paths and an expression that links the scene graph location created by that node to the path.

Replace with Node Graph Node Locations

Removes all existing paths and replaces them with a path for each selected Node Graph node and links the scene graph location created by that node to the path.

Append Node Graph Locations as Parameter Expressions  
Replace Node Graph Locations as Parameter Expressions  

Clear All

Removes all paths from this parameter.

Look File Pass Name Widget Type

The Look File Pass Name (lookfilePassname) widget type allows you to set the pass name to use from a chosen Look File. This widget type is not exposed for use as a custom user parameter, but can be accessed by setting the widget type hint to lookfilePassname. Node types that ship with Katana use the Look File Pass Name widget type for the passName parameter.

Parameters that use the Look File Pass Name widget type can be found on the following types of nodes:

LookFileMaterialsIn

LookFileOverrideEnable

LookFileResolve

Menu Command

Description

Choose Look File Pass from Selection...

 

Rectangle Widget Type

The Rectangle (rectangle) widget type allows you to specify rectangular bounds to use by a node. This widget type is not exposed for use as a custom user parameter. Several node types that ship with Katana use the Rectangle widget type for parameters of various names, for example: bounds, resolution, or rect.

Parameters that use the Rectangle widget type can be found on the following types of nodes:

Menu Command

Description

bounds or rect >

Copy from Monitor ROI  
Copy to Monitor ROI  

Scene Graph Location Widget Type

The Scene Graph Location (scenegraphLocation) widget type allows you to specify the path of an existing scene graph location that a node is meant to work with. Several node types that ship with Katana use the Scene Graph Location widget type for parameters of various names, for example: baseLocation, cameraLocation, location, locations, path, paths, sourceLocation, and targetPath.

Parameters that use the Scene Graph Location widget type can be found on the following types of nodes:

AimConstraint

GafferThree

OpScript

AttributeCopy

HierarchyCopy

OrientConstraint

AttributeSet

InfoCreate

ParentChildConstraint

BillboardConstraint

Isolate

PointConstraint

BoundsAdjust

LightLink

ReflectionConstraint

CameraClippingPlaneEdit

LightLinkEdit

Rename

CameraImagePlaneCreate

LightLinkSetup

RendererProceduralArgs

CameraScreenWindowConstraint

LightLinkEdit

RendererProceduralAssign

ClippingConstraint

LocationCreate

RenderOutputDefine

CollectionCreate

LookFileBake

RenderSettings

ConstraintCache

LookFileMultiBake

ScreenCoordinateConstraint

CoordinateSystemDefine

Material

Transform3D

DollyConstraint

NetworkMaterialInterfaceControls

TransformEdit

FaceSetCreate

NetworkMaterialParameterEdit

ViewerMaterialEdit

FOVConstraint

NetworkMaterialSplice

 

 

Menu Command

Description

Adopt Scenegraph Selection

The currently selected Scene Graph tab location is used to populate the parameter.

Adopt Selected Nodegraph Node

Creates an expression from the currently selected Node Graph node linking the scene graph location created by that node to this parameter.

Select In Scenegraph

Selects the location specified by this parameter in the Scene Graph tab.

Note:  This option may be included in both the dropdown menu and as an icon to the right of the parameter name, or may only be present in one of these locations.

Adjust Path Relative To 'basePath'

Converts the current targetPath to a path relative to the basePath. If the targetPath is an expression, it is converted to a constant.

Note:  This option does not appear in all instances and may only be available when both the basePath and targetPath parameters exist for a node.

Scene Graph Locations Widget Type

The Scene Graph Locations (scenegraphLocationArray) widget type allows you to specify a list of paths of existing scene graph locations that a node is meant to work with. Several node types that ship with Katana use the Scene Graph Locations widget type for parameters of various names, for example: destinationLocations, lightPaths, locations, paths, and rootLocations.

Parameters that use the Scene Graph Locations widget type can be found on the following types of nodes:

AimConstraint

InfoCreate

AttributeSet

LightLink

BillboardConstraint

LightListEdit

ClippingConstraint

LocationCreate

ConstraintCache

LookFileBake

ConstraintListEdit

LookFileMultiBake

DollyConstraint

PointConstraint

FOVConstraint

ScreenCoordinateConstraint

HierarchyCopy

 

 

Menu Command

Description

Path

Adds another path to this parameter's list of paths.

Append Scenegraph Selection

For each selected scene graph location, a new path is added to this parameter's list of paths and populated with the location.

Replace with Scenegraph Selection

Removes all existing paths and replaces them with paths populated with the currently selected Scene Graph tab locations.

Append Nodegraph Node Locations

For each selected Node Graph node, a new path is added to this parameter's list of paths and an expression that links the scene graph location created by that node to the path.

Replace with Nodegraph Node Locations

Removes all existing paths and replaces them with a path for each selected Node Graph node and links the scene graph location created by that node to the path.

Clear All

Removes all paths from this parameter.

Find Instances beneath Scene Graph Selection...

 

Note:  This option is only found on the rootLocations parameter.

Transform Controls Widget Type

The Transform Controls widget type allows you to manipulate the transformation matrix. This widget type is not exposed for use as a custom user parameter. Node types that ship with Katana use the Transform Controls widget type for the transform parameter.

Parameters that use the Transform Controls widget type can be found on the following types of nodes:

CameraCreate

GafferThree

LightCreate

PonyStack

PrimitiveCreate

TeapotCreate

Menu Command

Description

transform

interface

Sets the transform control layout:

SRT Values - exposes the scale, rotation, and translation controls.

Transform Matrix - exposes a matrix to control transformations.

Note:  If you select Transform Matrix, the translate, rotation, and scale fields are replaced by a matrix field instead.

transformOrder

Sets the order in which transforms are applied: Scale Rotate Translate, Scale Translate Rotate, Rotate Scale Translate, Rotate Translate Scale, Translate Scale Rotate, Translate Rotate Scale.

rotationOrder

Sets the order in which rotation is applied: XYZ, XZY, YXZ, YZX, ZXY, ZYX.

transform > interface: SRT Values

translate

Controls camera translation on the xyz axes.

rotate

Controls camera rotation on the xyz axes.

scale

Controls camera scale on the xyz axes.

transform > interface: Transform Matrix

matrix

Controls transformations using a matrix in place of individual SRT controls.

Note:  This field is only available if you have selected Transform Matrix in the interface field.

Transform Tools Widget Type

The Transform Tools widget type allows you to manipulate transformation data for scene graph locations. This widget type is not exposed for use as a custom user parameter. Node types that ship with Katana use the Transform Tools widget type for the transform parameter.

Parameters that use the Transform Tools widget type can be found on the following types of nodes:

CameraCreate

GafferThree

LightCreate

PrimitiveCreate

TeapotCreate

Menu Command

Description

transform > Tools

Snap to Position of Scene Graph Selection Moves the position of the light to the position of the item selected in the Scene Graph tab.
Copy Scene Graph Selection World Transform Copies the world SRT values of the item selected in the Scene Graph tab into the translate, rotate, and scale parameters under Object tab > transform.
Copy Scene Graph Selection Local Transform Copies the local SRT values of the item selected in the Scene Graph tab into the translate, rotate, and scale parameters under Object tab > transform.
Fit to Bounds of Scene Graph Selection Fits the light to the bounds set by the item selected in the Scene Graph tab.
Register to Scene Graph Camera

Places an object at a specified distance from a camera that is selected in the Scene Graph tab, oriented to face the camera, and scaled to fit the camera's screen window exactly. This is designed for use with primitive planes and may set unexpected transforms on other object types.

This option is only available if a camera or light is selected in the Scene Graph tab.

Reset Transform Resets any previous transforms, bringing the light back to the origin (0,0,0).