3D(OpenGL)视口

3D视口是最常用的界面Modo。它是进入的窗口Modo的虚拟3D世界。它有多种用途,可让您雕刻,绘制,设置动画,变形,移动元素以及定位相机和灯光。有这么多工作要做,因此灵活也很重要。3D视口中有许多功能,这些功能可让您根据手头的任务自定义所见以及所见。

什么时候Modo第一次打开,默认打开Model具有较大3D视口的布局Perspective视图。在检查视口时,您会看到一个深色网格在透视中移入一定距离,而另一个较粗的浅色网格垂直于深色网格。

网格显示

深色网格表示接地层,即Y(或上)轴的零位置。该网格的每个正方形代表一个固定的距离。由于此栅格是动态的,取决于缩放级别,因此右下角的小显示屏为您提供了每个平方单位的实际等效测量值,在50mm以上的情况下。

较浅的网格代表使用工作平面,这也是动态的,具体取决于您对世界的旋转方向。接地平面仅用于参考,而工作平面的目的是向您显示在3D空间中创建对象的位置。将其视为可动态调整到最合适角度的构造平面。

小费:  右键单击3D视口中的任何项目,然后选择Set Work Plane从上下文菜单中将工作平面与项目中心对齐。

同样在3D视口中,还有文本和信息叠加层,可为您提供有关视口中可见项目的相关信息,以及选择指南和当前选择的工具。所有这些都可以协同工作,提供重要的反馈意见,以加快和增强整体工作流程。

附加控制

为了充分利用3D视图,还可以在需要时直接访问许多其他控件。窗口的左上角有一个小圆圈,称为Thumb。旁边有三个胶囊状的按钮。的Thumb变为深灰色,直到视口变为活动状态,在这种情况下它将变为橙色。要激活任何视口,只需单击窗口框架内的任何位置。右键点击Thumb为您提供有关框架的一系列选项。看到使用布局控件有关选项的更多详细信息。

最左侧的胶囊按钮Thumb用于选择视口观看场景的方式(请参见工具平视显示器)。单击它以打开一个弹出菜单,允许您从“透视图”和各种等轴测视图的可用选项中进行选择,或者从“相机”或“灯光”的角度查看场景,或者雷·格莱选项为您提供场景的快速,完全渲染的视口内表示。的Viewport Textures图标可让您快速选择Environments, Matcaps和UV Textures显示在3D视口中,而不必将其添加到着色树。有关更多信息,请参见视口纹理。

右上角有几个小图标。前三个允许您操纵视图本身,移动,旋转和调整活动视口的缩放级别。单击并拖动任何图标可以进行适当的视图调整,从而提供一种直观的方式来操纵视口的虚拟相机的位置。要更轻松,更快速地进行视口导航,请参见导航。下一个是Minimize/Maximize箭头。单击以展开活动视口以填充整个本地框架,从而留出更多视口空间来操纵内容。箭头为黄色时,单击以最小化视口并显示其他关联的视口。

该齿轮包含所有可用的视口自定义控件选项。在这里,您可以更改几何图形在视口中的表示方式,控制线框叠加以及更改背景中项目的显示方式(可见但未选择的项目被视为背景元素),以及设置许多单个视口元素的可见性。也可以通过将鼠标指针悬停在目标窗口上并按来访问这些选项O在键盘上。有关视口自定义的更多信息,请参见下文。

右侧的小箭头图标称为Widget。有关此控件的更多信息,请参见使用布局控件。右键单击以打开一个弹出菜单,您可以从其中选择一个Modo视口。选择这些项中的任何一项都会将该窗口转换为选定的视口。

注意:  除非要更改,否则不要选择任何内容,因为视口更改无法撤消。看到自定义布局有关视口自定义(以及在需要时如何取回默认界面)的更多信息。

在视口的左下方,有一个XYZ轴Gizmo,它为窗口的方向以及当前的工作平面方向提供了可视参考。对于正交视图,该图标显示视口窗口面向的轴平面。在透视图中,您可以旋转视图并实时查看小部件更新。右下角有几个信息文本显示,这些文本动态更新,显示所选项目,通道和变形器的当前数量。GL显示参考了视口中活动的活动多边形的数量(包括Sub-D曲面),底部的数字给出了实际尺寸的参考,以参考地面平面网格中的正方形。显示的特定信息在显示偏好。

导航

Modo提供了许多功能来辅助GL视口的导航,从而允许您以各种方式在3D空间中导航。大多数是鼠标按钮和键盘组合。快捷方式基于默认接口值。有关其他导航选项,请参见输入首选项。

击键

行动

Alt+左键单击

旋转检视

Alt+中键

旋转视口Z轴(倾斜)视图

Alt+右键单击

释放鼠标时,“轻拂旋转”(也称为“随心所欲”)视图会变慢。

Shift+Alt+左键单击

平底锅视图

Shift+Alt+右键单击

仅上下摇摄

Ctrl+Alt+左键单击

缩放到鼠标位置

Ctrl+Alt+右键单击

框缩放(拖动框进行缩放)

. (期)

放大

, (逗号)

缩小

G

居中视图(当前鼠标到视口中心的位置)

/

转弯(场景的旋转视图)

Shift+/

直立

鼠标滚轮

将视图放大和缩小到鼠标指针

A

适合(缩放到场景范围/所有项目)

Shift+A

适合所选内容(缩放到所选元素)

Ctrl+A

对齐所选内容(将视图与当前所选内容对齐)

Ctrl+Shift+A

适合并对齐所选内容(将视图缩放并对齐至当前选择)

Ctrl+ Spacebar

显示一个饼图菜单。将光标悬停在任何选项上,然后松开以选择视图。

能见度

Modo提供了一种直接修改视口中对象可见性的方法。通常,您可以在项目清单改变了整个图层的可见性。以下命令根据选择模式仅允许临时切换所选元素(包括组件)的可见性。一旦隐藏,几何就无法编辑。要隐藏几何图形,请选择要隐藏的几何图形组件,然后在菜单栏中转到View > Hide Selected或按H在键盘上。要使几何再次可见,请单击View > Unhide或按U键。

注意:  保存文件并稍后重新打开时,所有隐藏的多边形都是可见的。

击键

行动

H

隐藏选定的几何图形(如果未选择,则全部隐藏)。

Shift+H

隐藏未选择的几何。

Ctrl+H

隐藏反转(切换可见性,反转当前状态)。

U

使所有隐藏的几何对于当前选定的图层可见。

锁定

通过提供与隐藏相似的功能,锁定使您可以修复选定的几何图形,使其不可编辑,但是仍然可见。

由威廉·沃恩(William Vaughan)提供

锁定项目层:

1.   在右侧面板上,打开项目清单,然后右键单击要锁定的项目。
2.   选择Lock/Unlock从下拉菜单中。

锁定图标出现在网格中的Items清单。

• 或者,在Properties所选网格项目的标签,打开Assembly标签,并设置Lock至Yes。有关更多信息,请参见装配视口。

您可以通过右键单击项目并选择来解锁锁定的元素Lock/Unlock。解锁后,锁定图标将被删除。

在3D视口中工作时,您可以锁定选定的组件以协助您进行工作流。Modo在3D视口中显示具有特定颜色的锁定的多边形,顶点和边。

注意:  在边缘选择模式下, Modo由于锁定的边缘元素与顶点或多边形元素相关联,因此还显示了锁定的顶点。

要在3D视口中锁定几何图形的零部件选择,请执行以下操作:

3.   在3D视口中,使用一种选择模式(“顶点”,“边”,“多边形”或“项”)选择要锁定的几何。

有关选择几何的更多信息,请参见选择项目。

4.   在菜单栏中,单击Edit > Lock Selected或按J。

小费:  您可以通过单击来解锁3D视口中的任何锁定元素Edit > Unlock或按I。

锁定键快捷键

行动

J

锁定选定的几何图形(如果未选择任何内容,则锁定所有几何图形)。

Shift+J

锁定未选择的几何。

Ctrl+J

锁定反转(切换所有几何的锁定状态)。

I

使所有锁定的几何体可编辑。

更改锁定元素的颜色:

1.   在菜单栏中,单击System > Preferences,展开Display ,然后点击Colors。
2.   下PSUB Masks,将Locked Mesh Elements通过单击并拖动字段中的值来获得颜色,或单击字段以打开“颜色选择器”以选择您的颜色。有关更多信息,请参见拾色器视口。

禁用Show Locked Mesh Items:

默认, Modo在视口中显示锁定的网格项目。您可以在视口属性中禁用它。

1.   在3D视口的右上角,单击齿轮图标以显示属性。

2.   打开Active Meshes标签,展开Shading部分,然后取消选中Show Locked Mesh Items。

工具平视显示器

在3D视口的每种布局中都可以使用Tool HUD。它是上下文相关的表单,其中包含每种布局的最新工具。它还会根据活动的选择模式显示不同的工具集。

要启用工具HUD,请按Ctrl/Cmd+Tab在键盘上。

首次打开Tool HUD时,它将为特定的布局和选择模式显示一组自定义工具。当您继续使用各种工具时,它们会被添加到左侧的Tool HUD最新工具部分。

单击“工具” HUD中的工具时,该工具将变为活动状态,并且其图标会以橙色突出显示,直到将其放下。

您可以通过以下方式将新工具添加到工具HUD: +右边的按钮。

要删除工具,请单击x在“工具” HUD中的工具图标的右上角。

您可以在3D Viewport Properties, 在里面HUD子标签。有关更多信息,请参见3D视口属性。

视口纹理

可以将预定义纹理应用于场景,以使用以下任意一种在3D视口中快速查看预览: 3D视口样式。提供了多种环境,MatCaps着色器和UV纹理。双击纹理时,场景将在3D视口中更新,而无需在场景中添加任何项目。 着色树。使用此功能使您可以在实际创建“着色器树”图层之前尝试不同的纹理。有关更多信息,请参见着色树项目层。

注意:  您在Shader Tree不被覆盖。查看您的套装Shader Tree项目,单击Render > Open Preview 然后单击箭头以渲染场景。

提供以下选项:

Option

Description

Environments

设置环境纹理后, Modo替换环境项中的Shader Tree。

Matcaps

设置MatCap着色器后, Modo完全替代了用于Shader Tree使用选定的MatCap着色器。

UV Textures

设置UV纹理后, Modo替换应用于网格表面的“漫反射”纹理,并使用默认材质。许多提供的UV纹理用于UV诊断。

注意:  将“ UV纹理”应用到“预设”网格时,“ UV纹理”的“ UV贴图”名称必须与“预设”使用的“ UV贴图”名称相同。
有关更多信息,请参见预设浏览器。有关重命名UV贴图的更多信息,请参见使用UV贴图。

查看类型

虽然视口没有实际的摄像头, Modo确实可以让您更改通过视口查看场景的方式。可以从以下选项中选择View Type视口左上角的菜单。单击按钮以打开菜单,您可以在其中选择其他选项。以下正交视图提供的视点不受所有基本观察平面-正面,背面,顶部,底部,左侧和右侧的透视失真的影响。

Front View

Back View

Top View

Front

Back

Top

Bottom View

Left View

Right View

Bottom

Left

Right

透视图类似于通过真实世界的相机查看场景,其中的显示器具有透视图和消失点。透视失真的程度可以在菜单栏中的Windows,在System > Preferences > Display > OpenGL设置Flatness of Perspective在Mac OS上, Menu > Preferences > Display > OpenGL设置Flatness of Perspective在(这是为了Perspective仅查看, Camera和Light视图由项目的设置控制)。此外,您可以从相机的角度观看场景,模仿项目的视野设置。当在Camera模式下,半透明的黑条会出现在框架上方,以表示渲染的框架的宽高比,用于与视口框架不匹配的宽高比。最后,还有Light从特定光源的角度显示场景的视图,提供了一种简便的方法来查看光源的指向和照明。

注意:  在导航时Camera要么Light视图中,实际上是在移动场景中元素的位置。

 

Perspective View

Camera View

Light View

Perspective

Camera

Light

雷·格莱

的Ray GL视口选项杠杆Modo的渲染预览功能与标准视口选项重叠,以提供渲染场景的混合显示,您可以在其中直接建模并与渲染场景进行交互。要使用它,请单击3D视口左上角的中心按钮,然后选择Ray GL。

有以下三个选项可供选择:

• Full -几乎接近最终渲染的质量水平,但减少了射线量,可以更快地进行交互。

• Fast -放弃纹理,可以更快地预览场景。

• Bake -提供烘烤预览。选择后,请从以下选项中选择:

• Bake Item -选择要用于烘烤的烘烤项目:

-- (Render Item) -通过渲染项目。

-- (Current Bake Item)-当前选择的烘烤项目。

-场景中的其他烘焙项目之一。

• Bake Output -从当前所选烘焙项目的可用输出之一中进行选择。输出可以是烘焙项目的渲染输出或纹理输出。纹理输出基于所选的纹理效果。

有关更多信息,请参见使用烘焙项目和烘焙工具

对于更简单的场景,阴影接近实时,就像在渲染预览中一样,但是对于更复杂的场景,在编辑之间会有一定的滞后,系统会暂时将其恢复为标准GL视图。用户可以控制Ray GL根据以下选项中的可用选项进行更新雷格Preferences可用Windows在System > Preferences > Display > Ray GL和,在Mac OS中Menu > Preferences > Display > Ray GL。另外,您可以选择渲染时要考虑的元素。例如,当您要为具有复杂毛发的对象建模时要禁用毛发渲染以加快预览速度时,此功能很有用。

RayGL viewport
Model courtesy of John Hayes

3D视口样式

Modo提供了多种使用视口样式可视化场景的方法。这些是视口内着色器,以特定方式显示几何图形,从而更容易可视化模型或场景的某些方面。您可以使用以下选项从可用选项中进行选择Viewport Options视口内的按钮(顶部左侧第二个按钮)。

布局

描述

线框

在里面Wireframe图纸样式仅顶点和连接顶点以使其成为多边形的边可见。实际的多边形面未绘制,因此,您可以通过模型查看背面的顶点和多边形边缘。

固体

的Solid着色模式可渲染几何图形而无需着色。当与线框覆盖图结合使用时,此模式最有用,从而产生平坦的渲染草图模式。

顶点贴图

的Vertex Map阴影选项使用当前选定的“顶点贴图”为模型着色。对于“顶点颜色”贴图,每个顶点的颜色与相邻顶点的颜色混合。对于“权重图”,正值用红色表示,而负值用蓝色表示。值为0或根本没有值的任何顶点都以绿色阴影显示。如果选择了颜色和权重类型“顶点贴图”,则“颜色顶点贴图”优先。

阴影的

的Shaded样式显示具有基本材质定义(例如漫反射,镜面反射和透明度)的网格。没有图像映射出现在Shaded样式。

质地

的Texture样式显示的网格表面仅具有最基本的材质属性,包括任何图像贴图纹理。在Texture样式,可以看到RGBA图像,将其alpha混合到下面的材质中。但是,标准Open GL的局限性迫使图像贴图绘制时不带阴影(即全亮)。这是用于3D绘画或在模型上放置图像贴花的一种合理的视图样式。的Shaded Texture样式可以使图像纹理着色,但不能使用Alpha通道。的Advanced 正确查看alpha会混合多个图像纹理层并对其进行适当着色。

阴影纹理

在里面Shaded Texture视图中,将图像贴图与阴影效果混合在一起即可看到。由于OpenGL的限制,此模式无法显示带有Alpha通道的图像,因此任何RGBA图像均显示为不透明的RGB图像。要从图像中查看Alpha通道,请使用Texture, Default要么Advanced查看样式。

高级OpenGL

的Default视图使您可以看到比普通效果更多的效果Texture视图。用Default模式下,您可以看到以下类型的图像映射:颜色,凹凸,镜面反射,发光和透明。它融合了每一层的多层(尽管凹凸只要使用第一层)。但是,您一次实际看到的总数是基于图形卡的资源的。这些资源限制是针对“着色器树”表面的,因此,如果您的卡具有8个纹理单位,则每个“材质”最多可以具有8个图像贴图。除了简单的Alpha混合之外,还考虑了每个图层的不透明度以及基础材质设置-例如,您可以将材质设置为50%透明,然后创建一个剪辑并将其应用为透明贴图并在区域中绘制完全透明或完全不透明(以前称为Advanced GL)。

古奇

的Advanced视口通过使用现代图形技术提供了更强大的渲染机制。此视口的目的是能够以交互方式产生与最终的场景离线渲染更接近的结果。除了支持“默认”视图之外, Advanced视口支持“物理着色器”,毛皮材质以及“环境光遮挡”和“直接光”阴影的反射和菲涅耳,并具有自己的视口抗锯齿功能。这些功能以及更多功能可以在“视口”选项面板中启用和控制(请参见高级选项)。Advanced Viewport需要至少具有OpenGL 3.2支持的图形卡,并且必须启用VBO模式。

激活后,切换按钮将显示在3D视口中,您可以选择着色模式。选择以下一项:

• Basic Materials

• Simple Materials

• Full Materials

注意:  组口罩 Advanced 3D视口中提供了对它们的支持,使您可以直接在视口中处理复杂的材质设置并实时进行更改。“高级3D”视口中的材质表示与“高级3D”视口中的材质表示几乎没有区别。 Modo的预览视口。

Cel阴影

的Gooch着色模式是一种顶点着色算法,它使用一种称为“色调着色”的技术显示几何图形。色调映射不是依靠传统的浅色到深色阴影样式的阴影(在工作时会遮挡模型的一部分),而是表示几何形状的曲率,从温暖到寒冷的阴影是温暖区域,而温暖区域通常是点燃凉爽的地方通常是阴暗的地方。使用此着色模式,您可以检查模型的表面是否具有适当的轮廓,同时仍可以看到整个网格均匀地发光。

反射

的CelShading样式会在模型上创建阶梯式阴影,使其看起来像是具有固定阴影区域数量的卡通。

反射

的Reflection着色器将您的几何显示为完全反射。该着色器使用三次反射贴图,并将一些原始材质属性与少量阴影混合在一起,以正确显示对象轮廓。当对模型表面进行视觉检查时,此模式非常有用,因为它有助于查找表面不规则性。

的RayGL着色器杠杆Modo的渲染预览功能与标准视口选项重叠,以提供渲染场景的混合显示,您可以在其中直接建模并与渲染场景进行交互。

的Fusion Profile着色器杠杆Modo的MeshFusion功能。

HMD质量预设可提供高质量的图像显示。选择预设之一,高,低,中或超,以获得更好的HMD性能。

小费:  如果遇到视觉性能问题,请选择较低的HMD质量预设。

有关更多信息,请参见选项,场景和性能。

高级OpenGL

的Model Base返回默认值Model选择上一个视口样式后进行布局。

的MeshFusion着色器杠杆Modo的MeshFusion功能可显示以线框绘制的网格:主网格为绿色,修剪为洋红色。它们在项目列表中也用颜色编码。

的Topology着色器在3D视口中显示“拓扑”预设。您可以在使用Model布局。

“保存视口预设”允许您将3D视图另存为预设,并指定是否包括“工程图”,“可见性”,“活动网格”,“非活动网格”和“高级”视口选项。完成后,该视口将列在“ 3D视口样式”下拉菜单中。

删除预设允许您选择要删除的视口预设。

有关的影片

渲染AVP

视口切换按钮

在场景中工作时,使用以下任意切换按钮可快速启用常用选项。

Viewport Textures

将预定义纹理应用于场景,以使用以下任意一种在3D视口中快速查看预览3D视口样式。提供了多种环境,MatCaps着色器和UV纹理。有关更多信息,请参见视口纹理。

Replicators

设置复制器在3D视口中的显示方式。提供以下选项:

• None -将所有复制器绘制为边界框。选择此选项可获得最佳性能。

• Selected -仅显示选定副本的阴影复制器。

• All -在3D视口中着色所有复制器。

Show Weightmaps

在3D视口中的几何体上显示选定的权重图。

Show UV Distortion

在3D视口中的几何体上显示UV变形。

注意:  必须选择UV贴图以使其在3D视口中可见。

Reference Item

将坐标系与所选项目对齐。

Show Locators

切换3D视口中定位器项目的可见性。

Overlay Drawing

切换定位器项目通过对象的可见性。

Make Inactive Invisible

在3D视口中隐藏不活动的图层。

Make Inactive the same as Active

以与活动图层相同的样式绘制非活动图层。

Transparency Overrides

使您可以区分背景线框和前景线框,因此您可以轻松了解正在使用的拓扑。该选项对于对较重的线框模型进行整理特别有用。

单击任何选项可设置活动网格的替代。Alt+单击选项设置非活动网格的替代。

提供以下选项:

Normal

默认设置。透明度替代被禁用。

Ghost

正面多边形以镜面高光绘制为半透明。背面多边形绘制为100%不透明。

X-Ray

正面多边形是透明的,并具有镜面反射高光。背面多边形绘制为100%不透明。例如,使用此模式可以轻松地选择具有绑定角色的关节。

模型由William Vaughan提供

注意:  透明覆盖不适用于Advanced视口或Wireframe模式。如果要在非活动网格上使用“透明度替代”,请确保未将其着色样式设置为Wireframe要么Advanced下3D Viewport Properties > Inactive Meshes > Shading > Shading Style。

 

您可以在其中的活动和非活动网格编辑透明度覆盖属性,例如不透明度值和线框颜色。 3D Viewport Properties下Active Meshes > Transparency Overrides和Inactive Meshes > Transparency Overrides , 分别。有关更多信息,请参见3D视口属性。

Basic Materials

当。。。的时候Advanced启用视口样式,显示基本的几何底纹和材质。使用此着色模式进行基本建模。

Simple Materials

当。。。的时候Advanced视口样式已启用,显示基本阴影,材质,阴影和IBL照明。使用此着色模式可以平衡速度性能和质量。

Full Materials

当。。。的时候Advanced启用视口样式,显示最高质量的阴影和材质。处理纹理和最终渲染时使用此模式Playblast。

注意:  着色器树设置的复杂性可能会影响性能。例如,如果父着色器项下有多个图层,则显示时间可能会更长。

高级视口切换按钮

当。。。的时候Advanced视口样式已启用,以下切换按钮显示在3D视口中。

Basic Materials

显示基本的几何底纹和材料。使用此着色模式进行基本建模。

Simple Materials

显示基本阴影,材质,阴影和IBL照明。使用此着色模式可以平衡速度性能和质量。

Full Materials

显示最高质量的阴影和材质。处理纹理和最终渲染时使用此模式Playblast。

注意:  着色器树设置的复杂性可能会影响性能。例如,如果父着色器项下有多个图层,则显示时间可能会更长。

视口光

您可以使用以下选项在3D视口中调整默认照明: View > Edit Viewport Lights。功能启用后,您可以在视口中单击并拖动以更改当前灯光的位置。其他属性可在Tool Properties对于Color和Intensity。Current定义要编辑的特定灯光。默认情况下有两个指示灯。您可以使用以下命令View > Add Viewport Light和View > Remove Viewport Light修改可见光的数量。

视口预设

在视口下Styles菜单中有保存视口的选项Preset使您可以捕获所有当前视口设置,并在以后轻松地调用它们。调用命令时,将打开以下面板。

在里面Name输入字段中,您可以为“预设”指定标题。一旦保存以供以后调用,此名称即出现在菜单中。选项开关代表在关联的视口“选项”面板(如下所示)中定义的各种选项,使您可以专门控制使用保存的预设调用哪个设置。直接在Save Preset option是一个附加命令,可让您删除任何用户创建的视口预设。

上下文菜单

通过在空白场景中的3D视口中单击鼠标右键,将显示一个上下文菜单,以帮助您进行设计工作流。选择添加到场景中的项目时,可以右键单击项目以查看上下文菜单,以显示另一组相关工具供您使用。以下是在空场景中显示的上下文菜单的示例。

Option

Description

顶点

将选择模式更改为Vertices。

边缘

将选择模式更改为Edges。

多边形

将选择模式更改为Polygons。

用料

将选择模式更改为Material选择。

物品

将选择模式更改为Items。

枢轴

将选择模式更改为Pivots。

中心

将选择模式更改为Centers。

创建

创建背景图片, 相机项目, 定位器项目 , 网格项目 ,以及许多其他建模操作。

原始

加一些添加基元到你的场景。

创建装配组

创建一个装配组。有关更多信息,请参见装配输入和输出

着色器

分配特定于图像着色器。

添加到选择集

将所选元素添加到选择集中。有关更多信息,请参见使用选择集。

调出选择集

调用任何现有的选择集。有关更多信息,请参见使用选择集。

套索风格

将套索样式更改为Lasso, Rectangle , Circle要么Ellipse。有关更多信息,请参见套索。

将OpenGL录制到电影

将场景另存为电影文件。有许多文件格式可用。

记录OpenGL到图像序列

保存你的图像序列。有许多文件格式可用。

记录Playblast

设置Playblast设置。有关更多信息,请参见Playblast。