共通パラメーターウィジェット

これらのウィジェットグループは、多くのノードに共通ですKatanaここで概要を説明します。ユーザーパラメータの追加と特定のウィジェットタイプの詳細については、 ウィジェットの種類そしてユーザーパラメータの追加。

アセットおよびファイルパスウィジェットタイプ

のAsset (assetIdInput)およびFile Path (fileInput)ウィジェットタイプを使用すると、ファイルシステム上のアセットおよびファイルに移動できます。付属のいくつかのノードタイプKatana使用AssetそしてFile Pathさまざまな名前のパラメーターのウィジェットタイプ、たとえば: abcAsset、 file 、 filePath 、 lookfile 、 procedural 、 saveTo、そしてsource。

を使用するパラメーターAssetそしてFile Pathウィジェットタイプは、次のタイプのノードにあります。

• Alembic_In

• LookFileGlobalsAssign

• AttributeFile_In

• LookFileMaterialsIn

• CameraImagePlaneCreate

• LookFileMaterialsOut

• ガファースリー

• LookFileMultiBake

• ImageCoordinate

• LookFileOverrideEnable

• ImageRead

• 材料

• LiveGroup

• RendererProceduralArgs

• LookFileAssign

• RenderOutputDefine

• LookFileBake

• ScenegraphXml_In

 

メニューコマンド

説明

ブラウズ...

ファイルブラウザまたはスタジオの資産管理ブラウザを起動し、使用する資産を選択できます。

パスからノード名を設定

ノードの名前を、ファイル名と一致するように変更しますが、パスまたは拡張子は使用しません。

属性名ウィジェットタイプ

のAttribute Name (attributeName)ウィジェットタイプを使用すると、属性を入力したり、 Attributesタブ、タイプのパラメーター上Stringユーザーパラメータで。ドラッグされた属性をドロップすると、ターゲットパラメータの値は、ドロップされた属性の値ではなく、ドロップされた属性の名前に設定されます。祖先グループ属性の名前は、ドットで区切られています。たとえば、 xform.translate。

を使用するパラメーターAttributeNameウィジェットタイプは、次のタイプのノードにあります。

• AttributeSet

メニューコマンド

説明

テキストフィールド

newParameter

から属性を入力するか、ドラッグアンドドロップしますAttributesパラメータの値を属性の名前に設定するタブ。

属性タイプウィジェットタイプ

のAttribute Type (attributeType)ウィジェットタイプを使用すると、ドロップダウンメニューから選択するか、 Attributesタブ、タイプのパラメーター上Stringユーザーパラメータで。ドラッグされた属性をドロップすると、ターゲットパラメーターの値は、ドロップされた属性のタイプの名前に設定されます。たとえば、 float。

を使用するパラメーターAttributeTypeウィジェットタイプは、次のタイプのノードにあります。

• AttributeSet

メニューコマンド

説明

テキストフィールド

newParameter

ドロップダウンメニューから属性タイプを選択するか、またはAttributesタブ、パラメーターの値を属性タイプに設定します。

CELステートメントウィジェットタイプ

のCEL Statement (cel)ウィジェットタイプを使用すると、ノードの文字列パラメーターに格納されているCELステートメントを作成および編集できます。付属のいくつかのノードタイプKatana使用CEL Statementさまざまな名前のパラメーターのウィジェットタイプ、たとえば: CEL、 cel 、 toCel 、 fromCel 、 celSelection 、 disableAt 、 exclusivity 、 lights、 objects 、 off 、そして on。

を使用するパラメーターCEL Statementウィジェットタイプは、次のタイプのノードにあります。

• AttributeCopy

• LightLinkEdit

• プルーン

• AttributeEditor

• LightLinkSetup

• RendererProceduralArgs

• AttributeFile_In

• ロケーション生成

• RendererProceduralAssign

• AttributeSet

• LodSelect

• ReverseNormals

• コレクション作成

• LodValuesAssign

• ScenegraphObjectSettings

• ガファースリー

• LookFileAssign

• VelocityApply

• GenericOp

• 材料

• ViewerObjectSettings

• LightLink

• OpScript

• VisibilityAssign

 

メニューコマンド

説明

ステートメントを追加

• Paths -追加PathsこのCELパラメーターのリスト。

• Collections -追加CollectionsこのCELパラメーターのリスト。

• Custom -追加CustomこのCELパラメーターのパラメーター。

• Append Scene Graph Selection -追加PathsこのCELパラメータにリストし、選択したシーングラフの場所を新しいリストに配置します。

• Replace With Scene Graph Selection -このCELパラメーター内のパラメーターをすべて削除し、新しいパラメーターを作成しますPathsリストし、選択したシーングラフの場所を入力します。

• Copy CEL Statement As Text -このCELステートメントをクリップボードにコピーします。

• Paste CEL Statement -このCELパラメーター内のパラメーターを削除し、クリップボードのCELステートメントをこのパラメーターに貼り付けます。

• Replace With Parameter Expression -現在のCELパラメーターを式に変換します。

パス>アクション

シーングラフ選択を追加

現在選択されているシーングラフの場所をこのリストに追加します。

シーングラフの選択を削除

現在選択されているシーングラフの場所をこのリストから削除します。

選択したパスを削除

これで選択されたパスを削除しますパスリスト、このリストから。

すべて選択

このリスト内のすべてのパスを選択します。

シーングラフで選択したパスを選択

このリストで選択したパスのシーングラフの場所を選択します。

選択したパスをクリップボードにコピー

このリストから選択したパスをクリップボードにコピーします。

拡張ビューを表示...

この内容のダイアログを表示しますパスリスト。

コレクション>アクション

シーングラフ選択からコレクションを追加...

現在選択されているシーングラフの場所からのコレクションのリストを含むダイアログボックスを表示します。その後、これらのコレクションから選択して、このリストに追加できます。

シーンルートコレクションを追加...

現在オンになっているコレクションが表示されたダイアログボックスを表示します/root。その後、これらのコレクションから選択して、このリストに追加できます。

選択したパスを削除

選択したコレクションをこのリストから削除します。

すべて選択

このリスト内のすべてのコレクションを選択します。

選択したパスをクリップボードにコピー

選択したすべてのコレクションとそのパスをクリップボードにコピーします。

選択したアイテムを「検索して選択」...

 

連合ドロップダウン

• 連合

• 差

• 交差する

CELウィジェットを持つすべてのノードで発生するわけではありません。初期ステートメントの後にウィジェットに追加された追加ステートメントでのみ発生します。

カラーウィジェットタイプ

のColor (色)ウィジェットタイプでは、RGBまたはRGBAコンポーネント値を直接指定して色を選択できますParametersタブ、またはカラーピッカーダイアログを使用します。付属のいくつかのノードタイプKatana使用Colorさまざまな名前のパラメーターのウィジェットタイプ、たとえば: bottomLeft、 bottomRight 、 color 、 constantColor 、 fadeToColor 、 gamma 、そしてpreviewColor。

を使用するパラメーターColorウィジェットタイプは、次のタイプのノードにあります。

• ガファースリー

• ImageColor

• ImageRamp

• ImageBackgroundColor

• ImageClamp

• ImageText

• ImageChannels

• ImageContrast

• ImageThreshold

• ImageCheckerboard

• ImageFade

• LightCreate

 

• ImageGamma

• ViewerObjectSettings

 

• ImageInvert

 
 

• ImageLevels

 

 

メニューコマンド

説明

色

指定されたパラメーターの色(RGBA値)。
選択範囲の色(RGBA)値を選択します。
>
平均 平均値を使用するようにカラーピッカーを設定します。
分 最小値を使用するようにカラーピッカーを設定します。
マックス 最大値を使用するようにカラーピッカーを設定します。
フロント フロント値を使用するようにカラーピッカーを設定します。
バック バック値を使用するようにカラーピッカーを設定します。
リリース時に自動無効化 マウスボタンを放したときにピッカーを自動的に無効にする機能を切り替えます。

色> RGB

赤

ピクセルの赤の値を設定します。

緑

ピクセルの緑の値を設定します。

青い

ピクセルの青の値を設定します。

アルファ

ピクセルのアルファ値を設定します。

カラー> HSL

色相

ピクセルの色相を設定します。

飽和

ピクセルの彩度を設定します。

軽さ

ピクセルの明るさを設定します。

アルファ

ピクセルのアルファ値を設定します。

カラー> HSV

色相

ピクセルの色相を設定します。

飽和

ピクセルの彩度を設定します。

値

ピクセルの値を設定します。

アルファ

ピクセルのアルファ値を設定します。

色のオプションの続き

表示変換を有効にする カラーピッカーのガンマ補正を切り替えます。これは、OCIOを使用する場合に特に便利です。
RGBAコンポーネントを制限する アルファを0,1に制限し、カラーチャンネルを0、aに制限します。

共通の2Dノードウィジェットタイプ

のCommon 2D Node (node2d)ウィジェットタイプを使用すると、特定の2Dノードの影響を受けるチャネルを選択し、マスキングパラメーターを指定できます。このウィジェットタイプは、カスタムユーザーパラメーターとして使用するために公開されていません。

のCommon 2D Nodeウィジェットタイプは、Image BackgroundColor、ImageChannels、ImageCheckerboard、ImageColor、ImageCoordinate、ImageCrop、 ImageRamp、ImageRead、ImageText、およびImageWrite。

注意:  すべての画像ノードにMaskパラメータ。

メニューコマンド

説明

[見る]

コントロールを設定するかどうかを指定しますmain、 left 、またはrightビュー、またはコントロールをEnable All。

特定のコンポーネント(R、G、B、またはA)が有効になっている場合、コントロールはそのコンポーネントのみに影響します。

混合

間の溶解bg 0の画像と1の完全なマージ効果。

Mask
チャネル

からのチャンネルout_maskマスクとして使用する入力:

• R -赤チャネルをマスクとして使用します。

• G -緑色のチャネルをマスクとして使用します。

• B -青チャンネルをマスクとして使用します。

• A -アルファチャネルをマスクとして使用します。

デフォルトでは、マージはマスクの非黒領域に制限されます。

反転 マージがマスクの非白領域に制限されるように、マスクチャネルの使用を反転します。
フリンジ

有効にすると、マスクが変更され、デフォルトでマージがフリンジ(半透明領域)に制限されます。

これは一般的なアルファ処理であり、通常のマスクを変更して、フリンジ(半透明)領域のみに影響を与えます。

新しいシーングラフロケーションウィジェットタイプ

のnewScenegraphLocation (newScenegraphLocation)ウィジェットタイプを使用すると、それぞれのノードによって作成されるシーングラフの場所のパスを指定できます。たとえば、 name CameraCreateノードのパラメーター。

このウィジェットタイプは、カスタムユーザーパラメータとして使用するために公開されていませんが、ウィジェットタイプヒントをnewScenegraphLocation。付属のいくつかのノードタイプKatana使用newScenegraphLocationさまざまな名前のパラメーターのウィジェットタイプ、たとえば: location、 locations 、そしてname。

を使用するパラメーターnewScenegraphLocationウィジェットタイプは、次のタイプのノードにあります。

• Alembic_In

• PonyStack

• カメラ作成

• PrimitiveCreate

• ImageCoordinate

• ScenegraphXml_In

• LightCreate

• TeapotCreate

 

メニューコマンド

説明

シーングラフ選択の親 作成されたオブジェクトの親の位置を現在のシーングラフの選択に設定します。
/ root / world / geo / ...の親 作成されるオブジェクトの親の位置を/root/world/geo/。
/ root / world / lgt / ...の親 作成されるオブジェクトの親の位置を/root/world/lgt/。
/ root / world / cam / ...の親 作成されるオブジェクトの親の位置を/root/world/cam/。
シーングラフを選択

このパラメータで指定された場所を選択しますScene Graphタブ。

注意:  このオプションは、 ドロップダウンメニューおよびパラメータ名の右側のアイコンとして、またはこれらの場所のいずれかにのみ存在する場合があります。

ロケーションウィジェットタイプ

のLocations (場所)ウィジェットタイプを使用すると、パスまたは式によってシーングラフの場所を選択できます。カスタムユーザーパラメーターとして使用するための公開されたウィジェットタイプではありません。付属のすべてのノードタイプのうちKatana、のみ分離するノードはLocationsウィジェットの種類、すなわちisolateLocationパラメータ。

メニューコマンド

説明

道

このパラメーターのパスのリストに別のパスを追加します。

表現  

シーングラフ選択の追加

選択したシーングラフの場所ごとに、このパラメーターのパスのリストに新しいパスが追加され、その場所が入力されます。

シーングラフの選択に置き換える

すべての既存のパスを削除し、現在選択されているパスが設定されたパスに置き換えますScene Graphタブの場所。

ノードグラフノードの場所の追加

選択された各Node Graphノードの場合、このパラメータのパスのリストに新しいパスが追加され、そのノードによって作成されたシーングラフの場所をパスにリンクする式が追加されます。

ノードグラフノードの場所に置換

既存のすべてのパスを削除し、選択した各パスに置き換えますNode Graphノードを作成し、そのノードによって作成されたシーングラフの場所をパスにリンクします。

ノードグラフの場所をパラメーター式として追加する  
ノードグラフの場所をパラメーター式として置き換える  

すべてクリア

このパラメーターからすべてのパスを削除します。

ファイルパス名ウィジェットタイプを見る

のLook File Pass Name (lookfilePassname)ウィジェットタイプを使用すると、選択したLook Fileから使用するパス名を設定できます。このウィジェットタイプは、カスタムユーザーパラメータとして使用するために公開されていませんが、ウィジェットタイプヒントをlookfilePassname。付属のノードタイプKatana使用Look File Pass NameのウィジェットタイプpassNameパラメータ。

を使用するパラメーターLook File Pass Nameウィジェットタイプは、次のタイプのノードにあります。

• LookFileMaterialsIn

• LookFileOverrideEnable

• LookFileResolve

メニューコマンド

説明

選択からLook File Passを選択...

 

四角形ウィジェットタイプ

のRectangle (長方形)ウィジェットタイプを使用すると、ノードで使用する長方形の境界を指定できます。このウィジェットタイプは、カスタムユーザーパラメーターとして使用するために公開されていません。付属のいくつかのノードタイプKatana使用Rectangleさまざまな名前のパラメーターのウィジェットタイプ、たとえば: bounds、 resolution 、またはrect。

を使用するパラメーターRectangleウィジェットタイプは、次のタイプのノードにあります。

メニューコマンド

説明

境界または rect>

モニターROIからコピー  
モニターROIへのコピー  

シーングラフロケーションウィジェットタイプ

のScene Graph Location (scenegraphLocation)ウィジェットタイプを使用すると、ノードが使用する既存のシーングラフの場所のパスを指定できます。付属のいくつかのノードタイプKatana使用Scene Graph Locationさまざまな名前のパラメーターのウィジェットタイプ、たとえば: baseLocation、 cameraLocation 、 location 、 locations 、 path 、 paths 、 sourceLocation 、そしてtargetPath。

を使用するパラメーターScene Graph Locationウィジェットタイプは、次のタイプのノードにあります。

• AimConstraint

• ガファースリー

• OpScript

• AttributeCopy

• HierarchyCopy

• OrientConstraint

• AttributeSet

• InfoCreate

• ParentChildConstraint

• BillboardConstraint

• 分離する

• PointConstraint

• 境界調整

• LightLink

• ReflectionConstraint

• CameraClippingPlaneEdit

• LightLinkEdit

• リネーム

• CameraImagePlaneCreate

• LightLinkSetup

• RendererProceduralArgs

• CameraScreenWindowConstraint

• LightLinkEdit

• RendererProceduralAssign

• ClippingConstraint

• 場所作成

• RenderOutputDefine

• コレクション作成

• LookFileBake

• RenderSettings

• ConstraintCache

• LookFileMultiBake

• ScreenCoordinateConstraint

• CoordinateSystemDefine

• 材料

• Transform3D

• DollyConstraint

• NetworkMaterialInterfaceControls

• TransformEdit

• FaceSetCreate

• NetworkMaterialParameterEdit

• ViewerMaterialEdit

• FOVConstraint

• NetworkMaterialSplice

 

 

メニューコマンド

説明

シーングラフ選択を採用

現在選択されているScene Graphタブの場所は、パラメーターを設定するために使用されます。

選択したNodegraphノードを採用

現在選択されているものから式を作成しますNode Graphそのノードによって作成されたシーングラフの場所をこのパラメーターにリンクするノード。

シーングラフで選択

このパラメータで指定された場所を選択しますScene Graphタブ。

注意:  このオプションは、 ドロップダウンメニューおよびパラメータ名の右側のアイコンとして、またはこれらの場所のいずれかにのみ存在する場合があります。

「basePath」を基準にしてパスを調整

現在を変換しますtargetPathに相対的なパスへbasePath。もしtargetPath式であり、定数に変換されます。

注意:  このオプションはすべてのインスタンスに表示されるわけではなく、両方の場合にのみ使用できますbasePathそしてtargetPathノードにはパラメータが存在します。

シーングラフの場所ウィジェットタイプ

のScene Graph Locations (scenegraphLocationArray)ウィジェットタイプを使用すると、ノードが機能する予定の既存のシーングラフの場所のパスのリストを指定できます。付属のいくつかのノードタイプKatana使用Scene Graph Locationsさまざまな名前のパラメーターのウィジェットタイプ、たとえば: destinationLocations、 lightPaths 、 locations 、 paths 、そしてrootLocations。

を使用するパラメーターScene Graph Locationsウィジェットタイプは、次のタイプのノードにあります。

• AimConstraint

• InfoCreate

• AttributeSet

• LightLink

• BillboardConstraint

• LightListEdit

• ClippingConstraint

• 場所作成

• ConstraintCache

• LookFileBake

• ConstraintListEdit

• LookFileMultiBake

• DollyConstraint

• PointConstraint

• FOVConstraint

• ScreenCoordinateConstraint

• HierarchyCopy

 

 

メニューコマンド

説明

道

このパラメーターのパスのリストに別のパスを追加します。

シーングラフ選択を追加

選択したシーングラフの場所ごとに、このパラメーターのパスのリストに新しいパスが追加され、その場所が入力されます。

シーングラフ選択に置き換え

すべての既存のパスを削除し、現在選択されているパスが設定されたパスに置き換えますScene Graphタブの場所。

Nodegraphノードの場所を追加

選択された各Node Graphノードの場合、このパラメータのパスのリストに新しいパスが追加され、そのノードによって作成されたシーングラフの場所をパスにリンクする式が追加されます。

Nodegraphノードの場所に置き換え

既存のすべてのパスを削除し、選択した各パスに置き換えますNode Graphノードを作成し、そのノードによって作成されたシーングラフの場所をパスにリンクします。

すべてクリア

このパラメーターからすべてのパスを削除します。

シーングラフの選択の下にあるインスタンスを検索...

注意:  このオプションはrootLocationsパラメータ。

変換コントロールウィジェットタイプ

のTransform Controlsウィジェットタイプを使用すると、変換マトリックスを操作できます。このウィジェットタイプは、カスタムユーザーパラメーターとして使用するために公開されていません。付属のノードタイプKatana使用Transform Controls変換パラメータのウィジェットタイプ。

を使用するパラメーターTransform Controlsウィジェットタイプは、次のタイプのノードにあります。

• カメラ作成

• ガファースリー

• LightCreate

• PonyStack

• PrimitiveCreate

• TeapotCreate

メニューコマンド

説明

変換する

インターフェース

トランスフォームコントロールのレイアウトを設定します。

• SRT値 -スケール、回転、および変換コントロールを公開します。

• 変換行列 -変換を制御するマトリックスを公開します。

注意:  選択した場合Transform Matrix、 translate 、 rotation 、そしてscaleフィールドはmatrix代わりにフィールド。

transformOrder

変換が適用される順序を設定します。 Scale Rotate Translate、 Scale Translate Rotate 、 Rotate Scale Translate 、 Rotate Translate Scale 、 Translate Scale Rotate 、 Translate Rotate Scale。

rotationOrder

回転が適用される順序を設定します。 XYZ、 XZY 、 YXZ 、 YZX 、 ZXY 、 ZYX。

変換>インターフェース:SRT値

翻訳する

xyz軸上のカメラの移動を制御します。

回転させる

xyz軸上のカメラの回転を制御します。

規模

xyz軸のカメラスケールを制御します。

変換>インターフェース:変換行列

マトリックス

個々のSRTコントロールの代わりにマトリックスを使用して変換を制御します。

注意:  このフィールドは、選択した場合にのみ使用可能ですTransform Matrixの中にinterfaceフィールド。

変換ツールウィジェットタイプ

のTransform Toolsウィジェットタイプを使用すると、シーングラフの場所の変換データを操作できます。このウィジェットタイプは、カスタムユーザーパラメーターとして使用するために公開されていません。付属のノードタイプKatana使用Transform Tools変換パラメータのウィジェットタイプ。

を使用するパラメーターTransform Toolsウィジェットタイプは、次のタイプのノードにあります。

• カメラ作成

• ガファースリー

• LightCreate

• PrimitiveCreate

• TeapotCreate

メニューコマンド

説明

変換>ツール

シーングラフ選択の位置にスナップ ライトの位置を、で選択したアイテムの位置に移動しますScene Graphタブ。
シーングラフ選択のワールド変換のコピー で選択したアイテムのワールドSRT値をコピーしますScene Graph変換、回転、およびスケールのパラメーターの下のタブObject タブ> transform。
シーングラフ選択のローカル変換のコピー で選択したアイテムのローカルSRT値をコピーしますScene Graph変換、回転、およびスケールのパラメーターの下のタブObject タブ> transform。
シーングラフ選択の境界に合わせる で選択したアイテムによって設定された境界に光を合わせますScene Graphタブ。
シーングラフカメラに登録する

で選択されたカメラから指定された距離にオブジェクトを配置しますScene Graphカメラに面する向きのタブで、カメラの画面ウィンドウにぴったり合うように拡大縮小されます。これは、プリミティブプレーンで使用するように設計されており、他のオブジェクトタイプに予期しない変換を設定する場合があります。

このオプションは、カメラまたはライトがScene Graphタブ。

変換をリセット 以前の変換をリセットし、光源を原点(0,0,0)に戻します。